Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2007-05-26
Last edited by nicolas_p - 2007-07-21

FS#7211 - Data Abort while music playback

Hello, the Rockbox builds are not working for me anymore, since while music playback the player crashes with a data abort.

This errors comes in both personal&patched builds (like cpchan’s build from the anythingbuticons forums and SVNs. I tried installing Rockbox, as well as installing the bootloader (with the latest sansapatcher.exe) several times.

I can not tell since which version the error occurs, but the SVN of the Mai 14th crashes on my play (I didn’t test any older version).

The weird thing is, that I have an older personal build from cpchan (his Mai 19th build), which is just working fine. But his latest build, as well the SVNs doesn’t anymore.

Closed by  nicolas_p
2007-07-21 12:38
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed. Reopen if not.

Anonymous Submitter commented on 2007-05-26 00:31

Just to clear, I mean May when I say Mai. I’m German, so I’m sorry for any language linguistique failure.

Please provide more information: What circumstances are these crashing happening under, with a current unpatched SVN build, what settings have you changed, what format is the file, etc?

Since you’re the only person experiencing this, we’ll need a lot more info.

lazka commented on 2007-05-26 06:27

Had the same thing.. The error came up about 20 sec after starting the playback.
I solved it by restarting the player immediately before the error appears. After that everything worked ok.

I will try to reproduce it and make a diff of the config/database whatever…

lazka commented on 2007-05-26 11:23

soo.. the data abort error is only present when there is no config.cfg (an empty one works).

lazka commented on 2007-05-26 11:52

I tried to find the first affected build.. the oldest (available) one 2007-04-26 has got the error as well.
I think nobody noticed it because most times the config is created before people start playing music or they just replaced the folder with a newer build.
And it only happens while playing music for 25-20+ seconds… plugins work fine.

I hope that I could help.

Anonymous Submitter commented on 2007-05-26 14:35

I had this error with a plain Rockbox SVN. Installed bootloader and extracted rockbox.zip on the player. I didn’t do any changes and didn’t create a config.cfg, just database building followed by a reboot. After that reboot I started to play music, and it crashed.

Anonymous Submitter commented on 2007-05-26 15:35

I had this error with a plain Rockbox SVN. Installed bootloader and extracted rockbox.zip on the player. I didn’t do any changes and didn’t create a config.cfg, just database building followed by a reboot. After that reboot I started to play music, and it crashed.

bas_k commented on 2007-07-03 09:40

Same here, rockbox used to work perfectly on my 1st gen Ipod nano 4g, but with todays daily build it always crashes after a couple of seconds of music playback. Anyone got any solution, even a dirty hack would be appreciated…

Anonymous Submitter commented on 2007-07-08 19:34

I didn’t had that for a long time. But that empty config.cfg helped. I didn’t delete it since the error came up, so I don’t know if the data aborts are still present on my player.

This should be fixed now. I’ll close this unless anyone reports a problem with a new build.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing