FS#7233 - Viewer icons without .icons file don't work

Attached to Project: Rockbox
Opened by Paul Louden (Llorean) - Tuesday, 29 May 2007, 12:24 GMT
Last edited by Jonathan Gordon (jdgordon) - Wednesday, 30 May 2007, 05:23 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Using the replacement white default icons it's become apparent that the viewer icons file isn't working appropriately without the presence of a .icons file.

Despite the icons being the right size, and in the proper order, they don't seem to be working at all, though the main set of icons seem to apparently work perfectly.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Wednesday, 30 May 2007, 05:23 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  filename was too long. if there is a blank .icons file it will work as expected
Comment by Paul Louden (Llorean) - Tuesday, 29 May 2007, 13:44 GMT
As an update, it seems it's not working reliably with an apparently correct .icosn file too.
Comment by Jonathan Gordon (jdgordon) - Tuesday, 29 May 2007, 14:13 GMT
Im not having much luck with the code either :( BUT I did figure out that the bmp's filename you suggested is longer than 32 chars so it wasnt reading either the bmp or the .icons...

unfortunalty, fixing filenames didnt fix it.

the attached patch _shuold_ work.. but doesnt :(