Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 8
  • Private
Attached to Project: Rockbox
Opened by mikerman - 2007-06-13
Last edited by linusnielsen - 2007-10-08

FS#7304 - Freeze Problem with Car Mode (Iriver H140)

Confirmed that this issue exists.

Target: iRiver iHP-140
Build: 6-6-07 bleeding edge (about 6 p.m. California time)

Switch car mode on, connect the player to power, and start playback. Either disconnect the power cord from the player or turn the power off. A press of play will start the player again. However, reconnecting the power cord instead to the player or turning the power on again, after 2, 5, 10 or 15 seconds, and the player freezes in 2-5 seconds and needs to be restarted with the reset button (and sometimes will boot into iRiver at that point).

Closed by  linusnielsen
2007-10-08 09:12
Reason for closing:  Fixed
Additional comments about closing:  

The problem was that audio_resume() was called in interrupt context. That is fixed now.

we have the 13th of June. 6th June is outdated. Please do not add tasks about outdated versions.

Additionally, using local time doesn’t help at all. Please provide the full version number, which includes the svn revision (thus making it possible identifying the _exact_ version you are using).

I appreciate the work you guy are doing with rockbox. I especially like Rockbox for the equalizer in my car, this is why I love the car adapter mode so much and would greatly appreciate it being fixed. Mikerman ‘s version might be an outdated version or not the exact build number,but in anycase just pick any build after the date Mikerman listed and it will have that bug. I have an h120 and I’m using todays build “rockbox-h120-20070614.zip” and it’s still not fixed. This problem started around the 2007-05-15 or before. Either way it’s still a problem. The boot into iRiver mode is not a problem, you just have to wait a few seconds after reboot to turn on or iRiver’s firmware loads instead. Happens with any resets as far as I can tell.

It would help us greatly if someone could work out exactly which build this problem was introduced… i.e. be able to state explicitly that it’s failing in buid rev 13385, but not in 13384. Failing that, if you can say for sure that it’s failing in builds from 15 May but not from 14 May.

I’d do this myself, but I don’t have an H1x0.

I apologize for having posted the bug report on an earlier build–at the time, I just hadn’t had Internet time to get the most recent build, and the problem had been chronic enough for weeks that I thought it merited posting. I will try to find time to update shortly. I noted this issue in the Rockbox forums on May 29 and thought that it had been occurring for 3 weeks or so, but can’t swear to the date of the start of the issue. (Originally, I didn’t think anything of the issue as I thought it was a car power issue of some type, not a firmware issue.) Sorry I don’t have further specifics.

And sorry by being dense, but by version number do you mean as listed in the opening splashscreen when Rockbox boots up? If so: Ver. r13579M-070607. Otherwise, just let me know where to look for the info.

I can confirm the current existence of this issue in the current Rockbox build.

Build version r13681M-070621. On an iRiver H140 player.

Turn car adapter mode on, and start playback; put the player into pause mode; attach AC current and the player freezes.
Turn car adapter mode off, and start playback; put the player into pause mode; attach AC power and the player does not freeze, and one may recommence playback.

Due to computer issues, I have not been able to test earlier builds to see when the issue may have emerged.

the version number you posted shows there have been changes made to the sources. Have you verified this problem with a clean build from build.rockbox.org? What modifications have been made to your sources?

Neff commented on 2007-06-21 22:59

I can’t say exactly when it started as for me it only happens intermittently but was definitely there in the 20070529 which was a clean build downloaded and installed with the Rockbox utility. I had it for at least a week before the 29th May, possibly longer.

The only changes made to my Rockbox version (which I quite simply had forgotten about): I still have a copy of the earlier Rockbox-included Chicago font on my system, modded to make the spacing of numbers constant (e.g. the numbers 1 and 9); and I had modified the contents of the opening Rockbox splashscreen bmp to also show my name and contact info. Unfortunately, due to computer issues right now, I am unable to build and load onto my player a build without these revisions. I know that this is dangerous to say, but could these 2 differences be affecting car mode and causing freezes (which others also have faced)?

Just tested this out with archived builds on my player, and build r13396M-070516 has this same issue; the bug does not exist in build r13327M-070505. The mods to these builds are the same as noted above in my prior post: a modded Chicago font and a modded opening Rockbox bmp. I hope this information helps.

And confirmed that the issue exists in today’s unmodded build, r13685-070622.

lixer commented on 2007-06-24 08:00

I’m experiencing the same exact problems on my 5G ipod with 2007-06-23 build.

Seeing this issue on my iRiver H10 20GB with build 13961-070722

Info from (duplicate)  FS#7344 :

Comment by Pav Grewal (lixer) - Sunday, 24 June 2007, 07:59 GMT — Edit — Delete
I’m experiencing the same exact problems on my 5G ipod with 2007-06-23 build.
Comment by Hung Nguyen (chucksplatt) - Monday, 23 July 2007, 18:40 GMT — Edit — Delete
There is a thread on the forum that is reporting that they are experiencing this on their Gigabeat F60.

I am now also seeing this on my iRiver H10 20GB. It’s looking like this is not isolated to any one piece of hardware.
Comment by Hung Nguyen (chucksplatt) - Monday, 23 July 2007, 18:42 GMT — Edit — Delete
Urp, probably should add some more helpful info:

The thread is here: http://forums.rockbox.org/index.php?topic=10551.0

And the build I have loaded is 13961-070722

Hi, I have an iRiver H140 and upgraded to the latest build last Friday night (r14029-070727). I can confirm this problem still exists, my player paused when the car’s power went off and crashed. I had to do a hard reset. I will now be downgrading to an old version that is not affected by this issue (r13146-070413). This problem is very frustrating, unfortunately I don’t know in which build the problem started occuring. The build that I will be downgrading too is from April!

havic commented on 2007-07-31 21:18

I have confirmed this problem exists on a Iriver H120 build date 20070730. I tried it both with my custom settings and with the settings reset to default with only car mode = yes. Same problems as listed in original details.

this sounds suspiciously like a problem seen on ipods. i’ve “fixed” the problem with a patch that disables pause mode – it’s stop playback instead. you might want to try it out. you’ll have to enable the patch for your specific player, but that is pretty easy.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing