Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by JonathanMueller - 2007-06-14
Last edited by Llorean - 2007-07-28

FS#7309 - Dynamic playlist and Play Next

I created a dynamic playlist from the database. Then I browsed through files and found a new song. Holding down the select button, I chose Playlist>Play Next. I pushed next to get to the new song. When the song finishes playing, it repeats and the playlist counter says “-55/1”.

Closed by  Llorean
2007-07-28 00:09
Reason for closing:  Invalid
Additional comments about closing:  

Cannot reproduce the actual "bug" part of this. If it comes back, please open a new task.

“Play Next” replaces the current playlist with whatever you had highlighted (folder, file). So when the current song ends, there is no playlist beyond whatever you’ve chosen with “Play Next” and anything you’ve “Insert”ed after.

I’m trying to understand, is there a bug here I’m missing, or are you reporting what is expected behaviour for the function, and just behaviour that you didn’t expect?

I guess that makes sense, function wise. I guessed it would insert the song into the current playlist.

I guess the bug would be the playlist counter saying “-55/1”. It should be “1/” at that point.

“Insert” is what inserts the song. “Play Next” means, act as if you’ve played this from the file browser. Next.

Ok, but what about the numbers problem?

That? That’s a genuine bug. Is it reproduceable?

Tried it again and wasn’t able to reproduce. This time it says “1/1” as it should. Don’t know what happened before.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing