Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System iPod Nano
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by elicriffield - 2007-06-18
Last edited by pondlife - 2008-03-09

FS#7324 - backlight doesn't come on until you shut it off then turn it back on

When I turn on my ipod nano 4g The LCD backlight does not turn on until i manually turn it off in
Settings → General → Display → LCD → Backlight → OFF then ON (or at this point i can set it to 5 seconds and it will work normal).

I’m using Version: r13666-070618
But i update about once a week and this has been happening for a while. It did work at one point, but i don’t know when that was. My work around is to set the backlight to be off when the hold key is on, then first thing after i turn the ipod on i turn the hold key on then turn the hold key back off then the LCD backlight starts working.

Eli Criffield

Closed by  pondlife
2008-03-09 18:31
Reason for closing:  Fixed
Additional comments about closing:  

Request a reopen if it's still a problem.

I just figured out that if backlight fadein is set to “OFF” everything works as expected
if backlight fadein is set to 500ms or 1s the backlight doesn’t come on at first boot untill forced off then on, like i mentioned in the bug.

Eli Criffield

Nix commented on 2007-12-09 11:54

Confirmed with SVN15899 on a post-backlight-rewrite iPod Video 5g.

More precisely, if backlight fade in is turned on, the backlight never turns on: if backlight fade out is turned on, it never turns off.

It looks like fading is broken (i.e., it entirely fails to fade).

Same problem with 80gig 5g running r15956M-071

Glad I found this report. I was putting rockbox on my dad’s new ipod for christmas and I know he wouldn’t tolerate this lack of backlight. I was about to copy over the old version of rockbox from my ipod just to get it working.

nls commented on 2008-03-07 23:31

Is this still an issue? If so could you try with reset settings (apart from the fade)?

Nix commented on 2008-03-09 18:05

Seemingly fixed at some point in the last few months. Fading in and out, separately and together, works for me now.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing