Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by woodyanna - 2007-06-20
Last edited by pondlife - 2008-02-09

FS#7334 - Follow Playlist doesn't work when playback is stopped.

I’m using an iPod Nano.
Here’s one way the problem occurs:
1. Open a folder containing more than one file and let Rockbox play at least part of more than one file.
2. Hold down Long Play to stop playback.
3. The name of the track that was being played is not spoken; typically either the name of the first file in the folder or the file I initially played will be spoken instead (I am using Talk MP3 Clips, so I assume whatever is spoken is also displayed, but I’m blind so can’t verify this).
I have Follow Playlist on, so I would have expected the name of the file I was just listening to to be spoken.

An even more confusing situation happens when I turn the player on and choose Resume Playback. Rockbox resumes as expected, but if I press long Play to stop playback, the name of the file I’m playing is not spoken. Instead, I’m in the root folder, as though I had just chosen Files from the main menu. When this behavior was discussed on the Rockbox Users list, I believe the consensus was that if Follow Playlist was on, one should be in the playlist that is being played, focused on the file that was being played just before playback was stopped.

Finally, I have Bookmark on Stop and Pause set to Yes and Load Last Bookmark turned on. When I enter a folder containing music and press Right, the song I most recently played begins playing, as expected. But if I stop playback with long Play, the first filename in the folder is spoken, not the name of the file that was playing before I stopped playback.

Thanks for looking into this, and please let me know if you have any questions about my report. I’ll be glad to help in any way I can.

Closed by  pondlife
2008-02-09 15:20
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed now. Let me know if not.

Hi Anna, please can you see if this is still a problem - it seems to work ok for me now (on H300). If any part is still failing, please attach your config.cfg file and explain again (in case I’ve missed something important).

Hi Steve,
Thanks so much for looking into this. Unfortunately, I’m still having the problem on my 2 GB iPod Nano.
1. Start playing a file.
2. Use the Forward or back button to move to another song.
3. Stop playback (not pause). The name of the first song is spoken, not the name of the song I was playing before pressing Stop.
I hope I’ve attached the right file. Please let me know if you need a different one, and thanks again.

Hi Anna,

Silly question perhaps, but are you using the database or file browser? Follow playlist doesn’t work using the database. It still seems fine under the file browser here FWIW.

Hi Steve,
I’m using the file browser. I’m also using a new (or possibly refurbished) iPod and am still seeing the same behavior, so the problem isn’t specific to my player. It’s so strange that Follow Playlist works fine for you and not for me. Thanks again for trying to help.
Anna

I have found that follow playlist doesn’t work if you use directory skip…

As part of cleanup week, I just tried the latest build, and if a different song is playing than the one that was playing when I first selected a file to play, I cannot hear the name of the song if I hold long play to stop playback. I tried pressing Select to go into the file browser first and then holding long play, but this didn’t help; I could hear the name of the song fine while music was playing, but not once playback was stopped. Since it’s sometimes hard to hear the track name over the music, it would be nice to have a reliable way of stopping playback and hearing the track name. The only settings that aren’t defaults at this point are:
Voice Directories and files are both set to spell, and Talk MP3 Clip is on for both
Follow Playlist is on.
The version number is R14187-070805 Thanks.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing