FS#7364 - Line-In Recording doesn't seem to work on iAudio X5

Attached to Project: Rockbox
Opened by Philip Barton (audiophyl) - Wednesday, 27 June 2007, 06:12 GMT
Last edited by Steve Bavin (pondlife) - Thursday, 28 June 2007, 07:33 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Summary says as much as I know. I've tried several builds, and am presently using the current build. Recording using the Microphone works as expected. FM Radio recording also works as expected.

Mayhaps everyone already knows this? I couldn't find any other bug reports regarding it.
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 28 June 2007, 07:33 GMT
Reason for closing:  Not a Bug
Comment by Michael Sevakis (MikeS) - Wednesday, 27 June 2007, 15:31 GMT
I find this odd since FM Radio is technically on Line-In also. The line input on the audio chip is multiplexed between Line-In and FM Radio. There is another report in the Users List. I cannot not reproduce the problem myself. Does it go away if settings are reset?
Comment by Philip Barton (audiophyl) - Wednesday, 27 June 2007, 19:53 GMT
Michael, I'm sorry to waste your time with this. I'm guessing the Line-In port is incapable of supplying power for a microphone, in which case it is no surprise that routing the microphone through my computer then back out to the X5 works fine. I double-checked the OF, as I seem to recall using a headset to record some notes... I must have fooled myself there, unless the headset I was using was somehow providing a much louder signal...
Comment by Philip Barton (audiophyl) - Wednesday, 27 June 2007, 19:59 GMT
Correction, I guess my headset is just a piece of garbage. On a hunch, I plugged the iAudio X5 earbuds into the Line-In port and used them as a microphone. Worked fine, so I guess Line-In must supply power.

Once again, sorry to have wasted your time!