Rockbox

Tasklist

FS#7366 - rb->set_int returning garbage when the maximum from the list is selected

Attached to Project: Rockbox
Opened by Joshua Simmons (mud) - Thursday, 28 June 2007, 05:57 GMT
Last edited by Steve Bavin (pondlife) - Thursday, 28 June 2007, 07:31 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Calling rb->set_int and selecting the maximum value from the list returns garbage results in the integer (once in a while I will get the expected answer, so please try it two or three times before you call me crazy). A simple plugin is included which exhibits this behavior on the simulator as well as on a sansa e280, with svn revision 13728 that I just checked out.

Again to reproduce this, build the plugin, run it and select the maximum value from the list (9).

If I am doing something wrong, please let me know but I don't see what it could be.
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 28 June 2007, 07:31 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Closed as requested.
Comment by Joshua Simmons (mud) - Thursday, 28 June 2007, 05:58 GMT
It seems I forgot to attach the .diff

Loading...