Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Games
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by sirdilznik - 2007-06-30
Last edited by jdgordon - 2008-11-28

FS#7378 - Buttons do not function/function incorrectly when running gameboy roms in sansa e280

The buttons do not function correctly anymore when running gameboy roms on my Sansa e280. I noticed this on a 6/29 build and it persists with a 6/30 build. I’m not sure when this first occured as I had not updated for almost a month previous to that and frankly had not played any gameboy games longer than that. The buttons used to work fine. Now both the right button and down (submenu) button translate to up/left. Right and up (play) seem to do nothing. I’ve tried this with several different roms and it’s the same with all of them. The buttons seem to work correctly in other applications.

Closed by  jdgordon
2008-11-28 03:15
Reason for closing:  Out of Date
Additional comments about closing:  

no reposnse from reporter and it seems to be a issue with custom keymapping anyway

Perhaps the Rockboy configuration file became corrupted (or somehow truncated)?
I don’t have a Sansa (proud Gigabeat F10 owner), so I don’t know what key normally corresponds to the menu function (and I’m too lazy right now to find it in the documentation). If you can access the options menu, you should be able to (re)set the key mapping to whatever you’re used to. Else, if you can’t access the menu, I’d recommend deleting the “options” file in the “/.rockbox/rockboy” directory (”X:\.rockbox\rockboy” on Windows, “X:” corresponding to your Sansa). Afterwards, starting rockboy as you normally would on the Sansa should make it write a new “options” file, and that should work fine.
Hope this helps! -queryno4

If you had quite some time to update then it is normal.
There were some changes on the Rockboy emulator some weeks ago, if you had the old version you had to put your settings again otherwise the buttons (and some other options) were set wrong.

Anyway did you try to set the keys again? Rockboy provides a way to set all the keymaps via the menu.
If that works, then this entry should be closed.

is this still an issue? have you tried with the latest build and reset the rockboy settings?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing