FS#7395 - Database update issues

Attached to Project: Rockbox
Opened by Daniel Rosenzweig (dzr) - Wednesday, 04 July 2007, 02:46 GMT
Last edited by Marc Guay (Marc_Guay) - Thursday, 27 March 2008, 13:17 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a Sandisk - but I don't know if it's model specific.

I already posted that the auto database refresh doesn't work -- but now it seems to attempt to do something on startup.. but it still doesn't work.

If I then MANUALLY do an initialize and update and reboot again manually, it ONLY shows the NEW files and not the old files. If I then reboot once again, it shows all of the files.

This is with today's official firmware build (and before).

So, it's more than just an automatic database update issue (and the automatic part may be fixed).

This is why I created a new ticket, to be more general. An admin may want to roll the old ticket into this new ticket.... but technically the old ticket MAY be solved, but since the automated functionality may kick off the manual functionality, it still doesn't work.

Other people have posted similar complaints. (At least on a third party forum). It's a pain to do this three boot thing, on the way to work!

This task depends upon

Closed by  Marc Guay (Marc_Guay)
Thursday, 27 March 2008, 13:17 GMT
Reason for closing:  Fixed
Comment by Daniel Rosenzweig (dzr) - Wednesday, 04 July 2007, 02:47 GMT
Ticket  FS#7240  is the original ticket regarding the automatic database update issue.
Comment by Daniel Rosenzweig (dzr) - Thursday, 02 August 2007, 01:25 GMT
Problem still exists August 1, 2007: r14133-070801
Comment by Marc Guay (Marc_Guay) - Tuesday, 11 March 2008, 18:25 GMT
Not having this problem on the Sansa e200 w/ r16601.