Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#7422 : Autoscore not displayed properly in WPS

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bascule - 2007-07-10
Last edited by pondlife - 2007-07-11

FS#7422 - Autoscore not displayed properly in WPS

Gigabeat F20 r13755
Autoscores displayed in the WPS (%ra tag) are missing the last character, so I get:

Autoscore Display
100 10
99 9
84 8

The code where I think it is displayed from in /trunk/apps/gui/gwps-common.c looks OK to my untutored eyes…

case WPS_TOKEN_DATABASE_AUTOSCORE:

          if (intval)
              *intval = id3->score + 1;
          snprintf(buf, buf_size, "%d", id3->score);
          return buf;

Topic http://forums.rockbox.org/index.php?topic=11470.0 refers

Closed by  pondlife
2007-07-11 08:03
Reason for closing:  Not a Bug
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Having asked around, this is intentional. Autoscores are stored in the file in the range 0-100 to give an extra decimal place, but they are actually ranged 0-10 (like ratings).

The problem is not in the WPS code, it's in the reading of the autoscore tag. tagcache.c contains the line:

  id3->score      = get_tag_numeric(entry, tag_virt_autoscore) / 10;

I'd guess that the idea was to bring scores and ratings (which are in range 0-10) into the same range, but it seems wrong to me. I'll ask on IRC and see if this behaviour is desirable. (I don't use autoscore myself.)

I also noticed that tagtree.c has the following line:

  id3->score      = tagcache_get_numeric(&tcs, tag_virt_autoscore) / 10;

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing