FS#7436 - Equaliser, Crossfeeder and Pitch-Shifter optimisations needed on iPod

Attached to Project: Rockbox
Opened by Mark (Xebozone) - Sunday, 15 July 2007, 02:41 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 15 July 2007, 06:57 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When enabling the software equaliser and/or the crossfeeder and/or the pitch-shifter (and possibly other features that modify the audio in real-time), the device begins to lag and has to rebuffer periodically as the buffer runs out.

The software equaliser is far worse than the crossfeeder, but both together is chaos! The Pitch shifter begins to lag at about 140-160% depending on the bitrate of the audio file.

Don't flame me now! I know this is expected because of the processing power needed to enable these features, but I would like the developer community to be aware of it if they currently are not which is why I have submitted this report. Hopefully further optimisations can be made to reduce the amount of processing power that is needed and hopefully eliminate the lag in most or all situations.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 15 July 2007, 06:57 GMT
Reason for closing:  Invalid
Additional comments about closing:  Performance issues are not a bug.

To make this work better good support for the second cpu is needed, which is being worked on.
Comment by Dan Everton (safetydan) - Sunday, 15 July 2007, 02:50 GMT
I believe the software equalizer is already as optimized as it's going to get. Similarly the other DSP code is already reasonably optimised. At some point you're going to have to accept that there are limits to the amount of processing that can be done with the CPU power available.