Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Oliver - 2007-07-23
Last edited by Nicolas Pennequin - 2008-01-09

FS#7471 - playback problems when in file browser

hi devs,

i had a strange bug: i had several vorbis-files from one album in my playlist. i listened to a song 3… it was just about to end (20 sec left). i wanted to go to track 9 afterwards. instead of moving in the playlist i went to the file browser, chose the file and selected “playlist → insert next”. i stayed in file brwoser when the track changed. there were some kind of “stuttering” (as if you start the song and go back a few times to the beginning before you really start -like sum-sum-summer…).. then it played ok. i tried to reconstruct the bug but that time it plyed fine. i had another smiliar (?) playback problem: as i once switched from file browser to wps during track change i got a “codec failure” message on the wps.. i stopped and played again, then it worked. (build: r13938 - 070720)

Closed by  Nicolas Pennequin
2008-01-09 01:10
Reason for closing:  Out of Date
Additional comments about closing:  

This isn't reproducible and the playback code has gone through a lot of changes since. Please open a new task if the issue is still present.

Steve Bavin commented on 2007-08-02 12:05

Hi Oliver,

Can you reproduce this at all? Do you use the “Advance Directory” feature?

Oliver commented on 2007-08-02 12:36

hi steve,

i cant reproduce it, no.
whats the “advance directory” feature all about
and where do i find it?

(btw: dunno if this is important but those files in my bug report werent vorbis-files, they were mpc)

Oliver commented on 2007-08-02 12:40

if you mean “directory cache” - yes, i use this.

Steve Bavin commented on 2007-08-02 12:40

Advance directory (my wrong terminology there) allows you to automatically listen to another directory/album when an album finishes; it has a couple of known issues, one of which results in similar symptoms to yours. The option is under Settings > General > Playback > Auto-Change Directory.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing