Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iPod 4G Color
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by mede - 2007-07-24
Last edited by Steve Bavin - 2007-07-31

FS#7472 - Undefined Instruction at 00058B40

Rockbox crashes after 10 minutes playing audio on my iPod 30G.

Steps to error:
1. start rockbox
2. begin listen audio without any manipulation on the ipod
3. after max 10 minutes rockbox crashes with the message

Undefined Instruction
at 00058B40

Rockbox is a cool alternative to the iPod software but when it
is not possible to play audio in a stable way it is sadly unusable

Closed by  Steve Bavin
2007-07-31 12:01
Reason for closing:  Fixed
Additional comments about closing:  

Seeing as it's Cleanup Week, I'll optimistically close this. Please request a reopen if required.

Steve Bavin commented on 2007-07-24 11:27

Do you definitely have the latest bootloader?

Admin
Linus Nielsen Feltzing commented on 2007-07-24 11:30

Which build of Rockbox is this?
Which audio format are you playing?
Are you using the file browser or the database browser?
Which WPS are you using?
Does it crash when playing certain songs?

When you don’t include any details to help us pinpoint the problem, your bug report is sadly unusable.

mede commented on 2007-07-24 11:43

i used the ipodpatcher downloaded 3.07.2007 size 376’832KB

using filebrowser
it crashes by certain songs

———————mp3 infos of one of this songs
Size: 5445696 bytes
Header found at: 107477 bytes
Length: 254 seconds
MPEG 1.0 layer 3
168kbit (VBR), 9732 frames
44100Hz Joint Stereo
CRCs: No
Copyrighted: No
Original: No
Emphasis: None

———————rockbox.info
Target: ipodcolor
Target id: 13
Target define: -DIPOD_COLOR
Memory: 32
CPU: arm
Manufacturer: ipod
Version: r13772-070703
Binary: rockbox.ipod
Binary size: 486160
Actual size: 486152
gcc: arm-elf-gcc (GCC) 4.0.3
ld: GNU ld version 2.16.1
Host gcc: gcc (GCC) 3.4.6 20060404 (Red Hat 3.4.6-8)
Host system: Linux

———————USED WPA (mede02.wps)
%al %id
%al %ia %?iy<(%iy)|>
%al %?it<%it|%>%fn>

%al %?Ia<%Ia|%D2>
%al %?It<%It|%Fn>

%al %pc %pt
%pb|10|10|215|
%al %pp of %pe
%al bat:%bl%
%wd

———————USED CONFIG
wps: /.rockbox/wps/mede02.wps
font: /.rockbox/fonts/nimbus-14.fnt
statusbar: off
brightness: 10
backdrop: /.rockbox/backdrops/mede.bmp
foreground color: AAAAAA
background color: 000000

Dominik Riebeling commented on 2007-07-24 11:47

This build is really outdated. Please use a current build before reporting any bugs (and make sure to follow our tracker guidelines that are linked from the submission page).

mede commented on 2007-07-24 12:40

i have installed the newest release and played some mp3 with the default settings
i have not changed any WPA or config

there was the same exception after 3 songs

Undefined Instruction
at 00058840

! 00058B40 was frong, think i couldent read it right with the font i used before

mede commented on 2007-07-24 13:00

NEW INFORMATIONS

Undefined Instruction
at 00058840

while playing 3th song.

———————mp3 infos of this song
Size: 2933460 bytes
Header found at: 512 bytes
Length: 183 seconds
MPEG 1.0 layer 3
128kbit, 7033 frames
44100Hz Joint Stereo
CRCs: No
Copyrighted: No
Original: Yes
Emphasis: None

———————rockbox.info
Target: ipodcolor
Target id: 13
Target define: -DIPOD_COLOR
Memory: 32
CPU: arm
Manufacturer: ipod
Version: r13969-070724
Binary: rockbox.ipod
Binary size: 487020
Actual size: 487012
gcc: arm-elf-gcc (GCC) 4.0.3
ld: GNU ld version 2.16.1
Host gcc: gcc (GCC) 4.1.3 20070601 (prerelease) (Debian 4.1.2-12)
Host system: Linux

—————USED CONFIG/WPA
default settings after installation
did no modification

Tom Gillam commented on 2007-07-27 10:20

I have had a similar problem with version r13891-070714 on the iPod 4G colour. I found that the problem goes away when boosting the processor frequency to 78MHz via System→Debug→CPU Frequency before playing any tracks.

Steve Bavin commented on 2007-07-30 12:01

Is this still a problem?

mede commented on 2007-07-30 15:00

Hmmm … My IPod is now playing audio since 2 hour without any problem.
Looks like the problem is fixed in the newest release.

I can say more after using rockbox a few days

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing