Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Language
  • Assigned To No-one
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by nls - 2007-07-24
Last edited by nls - 2008-04-03

FS#7475 - Hang when changing language (with voice) while music is playing.

To trigger this I start music, change language.
Music is stopped (I don’t know if thsi is supposed to happen)
Start music playback again and change language again.
Music playback stops and the gui is unresponsive, backlight still goes on and off though.

Reliably reproducible on h300 with r13968
I could not reproduce in sim.

Closed by  nls
2008-04-03 09:38
Reason for closing:  Out of Date
Additional comments about closing:  

I couldn't reproduce it with a current revision either… so let's close.

just tried on e200, change the language about 3 times (restarting music each time) and didnt get a crash

nls commented on 2007-07-30 09:53

Some more details:
This only happens when a voice file is loaded, I had an english.voice
file present and switched between English and Swedish.

64 bit sim crashes on mp3 playback so I can’t test voice stuff there :-(

nls commented on 2007-08-09 21:59

some more testing:

with music playing, changing from english (with voice file) to swedish and then back to english does work fine as long as playback isn’t started before I change back to english.

If I start up with swedish language (without voice file) and change to english menus are not voiced until I restart rockbox. If playback is started rockbox may hang, this is not as reproducible as the other hang.

And btw when rockbox hangs it does display the shutting down splash for a while (much longer than usual) if the stop button is long-pressed and then what seems like a hard power-off happends wiht a thump in the headphones.

Tested on e200 w/ 16929 and could not reproduce, though I’m not sure I understand the recipe perfectly. I had voice files for both english and finnish and went back and forth between the languages, pressing play in between, and had no problems. Care to try it again Nils?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing