Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Fed - 2007-07-25
Last edited by MikeS - 2007-08-06

FS#7480 - Sansa scroll wheel not recovering from standby

I have the unit on 5 seconds for backlight off, and 5 minutes for standby. The wheel brings back the backlight after 5 and 10 minutes, but not after 20 minutes or so. Other keys still do bring back the backlight. This has been since the recent changes to the sansa scroll wheel. The same problem persist with the current SVN.

Closed by  MikeS
2007-08-06 14:00
Reason for closing:  Fixed
Additional comments about closing:  

USEC_TIMER wrap was the reason.

Fed commented on 2007-07-25 16:04

After the scroll wheel does not work (to bring back the backlight from standby), it no longer works to bring back the backlight, even after 5 seconds. It seems a setting is changed.

The scroll wheel still works for all other things.

what setting are you talking about with the "5min standby"?

MikeS commented on 2007-07-26 01:07

I'm not sure where it comes from but it's been there awhile and way before standby was ever added or any scroll changes. The problem seems occur after exiting plugins as well as after a long time of "idle". The scrollwheel won't post messages unless the queue is empty in order to avoid overflowing it and prevent overscroll but I'm not 100% sure what's happening. It's really the only reason it could happen that I can think of. Ususally pushing a button will reset things. I always hit "|«".

Fed commented on 2007-07-26 01:20

I mean the "sleep (after backlight off)" setting in LCD settings.
Actually, I tried it with this setting off (ie no sleep after backlight off), and the same problem persists.

MikeS commented on 2007-07-26 01:32

That's what I thought. It's happened since before that feature but perhaps differently. It could also be that USEC_TIMER wraparounds occur more often than I expected and it doesn't count to 2^32-1. hmmm.

OT: you did ask me something about prerecording time in IRC. the answer was "yes" in case you didn't see but I forgot exactly what the question was. :\

Fed commented on 2007-07-28 11:52

I did ask about the prerecording. The question was whether or not it was possible to change the prerecording time after prerecording has stopped, but before recording itself has started. Basically, I'd like to have prerecording set for a few minutes, and when I am ready to record, I chose the prerec time that I'd like to keep, then press record tocapture it, and then continue recording.

MikeS commented on 2007-07-29 10:41

OT: prerecord never stops except with a time of "0" but just loops over the oldest encoded data. the entire buffer will fill but atm only what the menu option specifies is kept. when recording is started and it is given a filename to write is when the prerecorded data is committed to be flushed to that file. the specified amount could actualy be changed at any time. it will only care about the value when you hit "record" and it searches back until it has gathered that amount. this event flags the appropriate chunk as the beginning of a file and the name of the file is queued to be opened and written upon flushing the buffer.

Fed commented on 2007-07-29 13:23

I have tried several things, and now I am sure that this problem with the scroll wheel is relatively new. After a certain amount of time being idle, the scroll wheel does not bring the backlight back. |« does not seem to reset things. I have to reboot in order to reset things. I am 100% sure this did not happen before the changes to the sansa scroll wheel. I am sure because I am using the unit in the same way I was before - I use it mainly as a voice recorder. I find this problem interferes with proper use. I'll try to find the change that made this problem.

OT - I made some changes where I can now change the prerec time (using the scroll wheel in the recording screen, not using the menu) after prerec started, but before rec started. When I start recording, it prerecords using the value of the prerec before you start prerecording. It seems that in order to use the new prerec value, you have to exit and start prerecording once again.

MikeS commented on 2007-08-05 14:15

Fed, if you would so kindly, try this little patch out and see what happens.

Fed commented on 2007-08-05 14:51

I'll give it a try.

I've been trying to test some more, to get an idea of where the problem is. I'll let you know when I come up with something.

Fed commented on 2007-08-05 18:49

I'll give it a try.

I've been trying to test some more, to get an idea of where the problem is. I'll let you know when I come up with something.

Fed commented on 2007-08-05 23:14

It seems to be working fine now!

Thanks a lot,

Fed

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing