Rockbox

Tasklist

FS#7665 - ipodpatcher does not recognize 2g iPod (Fat32)

Attached to Project: Rockbox
Opened by Philip Sandiford (sandifop) - Sunday, 26 August 2007, 17:58 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 26 August 2007, 19:54 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System iPod 1G/2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

ipodpatcher does not recognize a 2g (Firewire) iPod. iPod formated Fat32, put into diskmode and .rockbox directory created by un-zipping to the iPod.

Failed in both XPsp2 and Mac OS X 10.4.9. Mounted drive, "unmounted" in Disk Utility, launched ipodpatcher, Terminal reported:

[INFO] Scanning disk devices...
[ERR] No ipods found, aborting
[ERR] Please connect your ipod and ensure it is in disk mode
[ERR] Also ensure that itunes is closed, and that your ipod is not mounted.
[ERR] Please refer to the Rockbox manual if you continue to have problems.

Press ENTER to exit ipodpatcher :
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 26 August 2007, 19:54 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  ipodpatcher needs to get an updated binary ...
Comment by Dominik Riebeling (bluebrother) - Sunday, 26 August 2007, 18:31 GMT
have you build the bootloader from svn or downloaded the binary? The binary hasn't been updated since the addition of the 1G / 2G ipods.
Comment by Philip Sandiford (sandifop) - Sunday, 26 August 2007, 19:41 GMT
I'm too noob for this territory. I'll check back in a year and see if the project is ready for "users."
Comment by Dominik Riebeling (bluebrother) - Sunday, 26 August 2007, 19:54 GMT
The project is quite "ready for users" (as long as you have some technical knowledge). The problem in your case is simply that ipodpatcher hasn't been updated yet. This should be done in the near future.

Loading...