Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by chrisjs169 - 2007-09-10
Last edited by Marc_Guay - 2008-07-11

FS#7744 - Leaving Mazezam Idle causes shutdown.

If you begin a game of mazezam on the Sansa (other targets unknown) and go to the quit menu, but leave it idle (don’t select anything) it shuts down within about ten or 15 seconds. Rockbox doesn’t have the “shutting down..” message so it could be possible that it’s somehow registering the power button as being held.

Closed by  Marc_Guay
2008-07-11 00:15
Reason for closing:  Invalid
Additional comments about closing:  

New version works fine.

petur commented on 2007-09-10 22:14

No problem on my iriver and on the sim, so this may be target specific.
I see nothing special in the code either.

I guess that what you see after 15 seconds is the backlight going out, are you sure it is switching off?

petur commented on 2007-09-10 22:17

Heh… I write this comment and 1 minute later I see it happening :)
I did have to press some keys in the quit menu for it to happen though, just entering it and not touching anything does nothing.

petur commented on 2007-09-10 22:56

I changed the code to keep the backlight on while in the game, maybe something gets sprinted on the screen before it shuts down?

I am again not able to reproduce, very strange :/

I’ve given it a try, but I’m not able to reproduce this bug. I’m using a Sansa C250 with an untouched rockbox build: Rockbox r16850-080327.

I’ve changed lots of MazezaM in  FS#8861 . If possible, can someone confirm whether this bug is still a problem? (I was never able to reproduce it).

A new version of MazezaM is in SVN. Can someone confirm whether this bug still applies?

Cannot reproduce on the e200 w/ 17071. I did notice however that you cannot return to the MazezaM main menu from the Audio playback menu, both “left” and “power” take you back to the game itself.

Here’s a patch which solves the playback menu issue.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing