Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Database
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jeton - 2007-09-11
Last edited by sideral - 2011-04-18

FS#7754 - Better Data collection for Most Played.

The Database seems to consider as “played” the songs that are played only 1-3 seconds (i.e. while skipping them).

A better solution would be to have a sort of scrobbling option, where we can set a certain amount of time when the song should be considered as “played”. In percentage maybe , 50% or less.

Closed by  sideral
2011-04-18 13:31
Reason for closing:  Fixed
Additional comments about closing:  

Since r29250 we don't log DB changes unless the track has played for at least 15 seconds (or is shorter and has completed playback without being interrupted). (SWCODEC only, alas – for HWCODEC tagtree_track_finish_event cannot discern between automatic and user-triggered track change.)

I think conditions to what is considered as played might be controversial… Although this can be easily modified in function tagtree_unbuffer_event in apps/tagtree.c, so you can change what is written back to database to whatever you like.

jeton commented on 2007-09-12 12:03

The problem is that I sometimes push the Next button and a song starts, and in a period of seconds a go to the next one. Rockbox counts that song as played…

Well, then what is considered as played if I have a bunch of 1-2 second pieces (yes I do have them)?

Although I personally don’t really have any use for this, I have a quick dirty patch for your personal use (if you want it) - if only 1.5 second or less is played, this patch considers the song as unplayed and do not update any runtime statistics. And you can modify the 1.5 second to whatever you want (the time is counted in milliseconds, so replace 1500 with 2000 if you want 2 seconds of grace period). The patch is totally untested, but I don’t see any harm to it.

jeton commented on 2007-09-12 14:17

Thanks for the patch. As I don’t know to create a custom build I’m gonna ask cpchan or chrisjs to add it to their build.

This actually was the idea, to give the user an option to choose the time when a song is considered as played. Last.fm uses this method for the scrobbling of the songs you play.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing