Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Database
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by polygonal - 2007-09-28
Last edited by jdgordon - 2010-11-17

FS#7858 - tiny improvement on tagtree.c

Currently tagtree.c parses everything from tagnavi file(s), which is unnecessary because once a root menu is found, nothing more is needed since only the first root menu is used and anything used by that should be defined before the root_menu statement.

So I basically tell the parser to stop as soon as a valid root_menu is set. Obviously this fix is not a big deal, but the parser annoys me because it produces a lots of useless logf’s when I tried to debug my own custom_tagnavi file that sets a different root menu.

I also removed a obsolete comment (the syntax in that comment is out of date).

Closed by  jdgordon
2010-11-17 05:08
Reason for closing:  Not a Bug
Additional comments about closing:  

see the last comment

oops, sorry about the crlf ending… TortoiseSVN changed it without me knowing.

petur commented on 2007-10-01 19:46

tortoiseSVN works native, so all files it works with are CR-LF on windows

Resync (just offset lines)

The reasoning does not appear to be valid: A root_menu can use other menus defined after itself. For example, a root_menu defined in a tagnavi_custom.config can refer to menus defined in tagnavi.config after tagnavi_custom.config has been included.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing