FS#7953 - playback jitter?

Attached to Project: Rockbox
Opened by Jim (istudio) - Sunday, 14 October 2007, 18:39 GMT
Last edited by Dominik Riebeling (bluebrother) - Monday, 15 October 2007, 16:24 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


i am not quite sure whether it is my ipod nano can't process too much sound settings or something else...

for sometime, i can usually hear "jitter" sound (like the DVD player is reading a dirty disc).

at first i thought it was my track but when i rewind it then it doesnt happen again?
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 15 October 2007, 16:24 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Performance issue, see the FAQ: in/IpodFAQ#Playback_is_glitchy_skips

We do not provide any support in the tracker. Use the support channels and check the FAQ first the next time.
Comment by Nils Wallménius (nls) - Sunday, 14 October 2007, 19:48 GMT
If you mean that the music stops briefly then yes it is most likely due to too much sound processing, try turning some off. Also you can check how much cpu is used if you go into the system->debug->view audio thread screen and look at the boost %
Comment by Jim (istudio) - Monday, 15 October 2007, 16:02 GMT
constantly 100% at 80MHz.... once i turn on the Graphic EQ then it will do that? so -> that means i cant use EQ?
Comment by Nils Wallménius (nls) - Monday, 15 October 2007, 16:17 GMT
There are many things that use cpu time, you obviously have your player do too many cpu demanding tasks at once.
One big factor is the encoding format you use for your music and which bitrate it is in, generally higher bitrates are slower and performance varies a lot between codecs.
All dsp effect, like every band of EQ, dithering, crossfeed, replaygain etc. use a bit of cpu.
Another big cpu hog is the peakmeter that is displayed on some wpses.

So do this: use a theme without peakmeter, disable as much dsp as you can, remember that every _band_ of eq counts so try using fewer bands etc. If you really need all that dsp, consider switching to a codec with a faster implementation in rockbox.

Also this is a support issue and not a bug and so it does not belong in the tracker, I will close this task tomorrow.