Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System Archos Player
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by tspoon - 2007-10-15
Last edited by speachy - 2020-08-14

FS#7960 - Shows Ata Error instead of charging screen.

When the dc jack is plugged in to charge while the player is not running (switched off), the display says ‘ATA Error -11’. It can’t be reset except by removing the batteries and dc jack. I ran an older build from last year and it works fine.

Closed by  speachy
2020-08-14 14:24
Reason for closing:  Out of Date
Additional comments about closing:  

We've dropped Archos support going forward.

If this bug is still relevant (and anyone cases) with the latest release, re-open.

Actually the message says '*PANIC* ata: -11'.

Concur. Thought my HD had died there for a moment until I did some trial and error. Noticed the same thing you did on my Archos FM Recorder. It looks like it has something to do with the shutdown function when plugged in. I would think it would show the shutting down screen then come back up with the battery charging screen but it just locks up as you described.

Thanks for posting, saved me a lot of trouble as I was contemplating replacing the HD.

I believe this may be related to: http://www.rockbox.org/tracker/task/7631 I'm quite happy with how my V2 recorder works now and I haven't noticed any harm from disabling low battery shutdown.

doldi commented on 2008-07-14 13:37

Some other peoples write also in forums about this Problem.

I have 4 Recorders and 5 Players, all very good soldered ;-), new Aku inside, Hardware ok -
and with current build display this Problem *Panic*: ATA-11 on all AJB.

Player and Recorder would correct charge:
1.) with current builds, if You touch the (-) Buttom and put in the Charger - or -
2.) with TAC's Rockbox 2.5.1 (unsupported build)

Greetings doldi

Several changes should have improved the the situation.
- init() didn't detect the charger and display the charging screen, because charger_inserted() depended on the power management thread. This was fixed via  FS#10091  in r20634
- The charging screen quit because of an improper test for a USB connection. This was fixed in r17955.
- On all except the original recorder, ata_init() didn't call ide_power_enable(true) because ide_powered() returned true when HAVE_ATA_POWER_OFF wasn't defined. This was fixed in r25593 by making ide_powered() always return the real IDE power status. However, this doesn't explain why the recorder got ATA panics.

So, does this problem still occur on players and original recorders?

I can only think of one problem which remains: on FM and v2 recorders, IDE power is needed for measuring battery level (NEED_ATA_POWER_BATT_MEASURE). The power management thread starts before the charging screen, and if it sees an extremely low level, it causes a low battery shutdown. However, I don't think that would lead to an ATA panic.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing