Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by ddalton - 2007-10-21
Last edited by pondlife - 2008-02-09

FS#8003 - Crashes when scroling through voiced menus quickly

When scroling through menus with long names and tapping down or up quickly in a row the player chrashes.

Doesn’t happen all the time but I have found it happens a bit in the display settings. It seems to be a voice problem.
I have only tested with voice menus enabled.

If you hold down or up it is fine and if you don’t tap quickly it is fine also.

Maybe we should only voice the current menu option if there hasn’t been a key press for 0.3 s? Action_none is far too long…

Closed by  pondlife
2008-02-09 15:59
Reason for closing:  Fixed
Additional comments about closing:  

Voice has been largely redone, and no recent reports.

If possible, please check if it happens without voice menus enabled. I had a crash last week when scrolling the tree view without voice enabled.

Also, are you using a gradient highlight bar?

If possible, please check if it happens without voice menus enabled. I had a crash last week when scrolling the tree view without voice enabled.

Sorry I am blind and that might be a bit difficult.

Also, are you using a gradient highlight bar?

What’s that? How do I check?

It also happens on an iAudio X5 running r15295. But I’ve encountered this bug before the recent “simple list” commits too.

Please can someone who’s still seeing this problem post their config.cfg. Or is it now fixed…?

LinusN fixed a buffer overflow causing a corruption/hang in the menus ( FS#8163 ). This was in r15633. Has this fix also resolved this?

I can’t reproduce, although that has been the case with earlier builds. It just sometimes happens out of nothing. If I encounter this bug again I’ll post here.

Project Manager

There has been some major changes to the voice codec system. Could you please test again with the latest build and the latest voice?

I can’t reproduce the bug, but I haven’t done extensive trying. I may do that this weekend.

Another thing that has been introduced since the recent changes is that the sounds in the voicefile cut off a little too early, so that the talking of numbers is a little fast. (I know this doesn’t belong here, sorry. ;))

I had one crash this morning on my build of 15862. I had some patches installed but it was in the voice menu… They don’t really touch there. Anyway I have only used this build for a few hours so I’ll give it a week and if mine is ok and no one else reports this happening I will close the task.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing