Rockbox

Tasklist

FS#8095 - Incorrect song position display on WPS

Attached to Project: Rockbox
Opened by Mark (Xebozone) - Monday, 05 November 2007, 04:16 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 06 November 2007, 07:34 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have tested this on my iPod 30GB 5G. I don't know if the same problem occurs on other players.

When a song is mid-way through playing and stop is pressed (long hold of the play/pause key) the song stops and returns to the menu.

However, pressing "resume playback" will start the song again, but the position of the song will read the same time as the place it was last stopped.

The remaining time displayed will be the remaining time that was previously + the duration of the song.

To reproduce:

1. Play a song part-way (you can fast-forward a bit if you want)
2. Press STOP
3. Press "Resume Playback" on the menu
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 06 November 2007, 07:34 GMT
Reason for closing:  Fixed
Comment by Mark (Xebozone) - Monday, 05 November 2007, 09:59 GMT
Correction: The remaining time displayed is not remaining time that was previously + the duration of the song.
Comment by Steve Bavin (pondlife) - Monday, 05 November 2007, 13:12 GMT
The problem I see is that audio playback begins from the start of the track again, although the WPS displays (correctly) the position where resuming should happen.
Comment by Steve Bavin (pondlife) - Monday, 05 November 2007, 13:30 GMT
This got broken in revision 15465. I'm using MP3 by the way.
Comment by Steve Bavin (pondlife) - Monday, 05 November 2007, 18:47 GMT
Hi Mark,

Seems fixed for me in r15482 - how is it for you? If it's still a problem, what file format are you using?
Comment by Mark (Xebozone) - Tuesday, 06 November 2007, 06:46 GMT
Yes...that's not happening any more...but that's because the song is resuming the last position now.
Is it supposed to resume the last position after stopped or is stopping it supposed to make it go back the the beginning of the song once resumed, because that's what was happening before?

If it's supposed to make it go to the beginning, then there is a different problem (this was the behaviour at the time of reporting of the bug).

If not, then this flyspray can be closed...

Oh, and I was using MP3.
Comment by Steve Bavin (pondlife) - Tuesday, 06 November 2007, 07:34 GMT
It's meant to resume, like it does now.

Loading...