Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Nicolas Pennequin - 2007-11-06
Last edited by Nicolas Pennequin - 2008-07-08

FS#8102 - Audio glitch at beginning of new playlist

I’ve noticed an audio glitch when starting to play a new playlist after the previous ended with no silence.

Here is the reproduction recipe I use:
- With playback stopped, start a new playlist with a single MP3 file that ends without a silence.
- Once the track is buffered, seek to a point near the end of the track.
- Let the track finish playing.
- Start a new playlist by selecting a track in the file browser. The last few split seconds of the track that previously finished playing should be played again right before the first track of the new playlist starts playing.

I’m not sure whether this glitch would still appear if the first played track is not an MP3. It’s also probably not necessary to have just one track in the playlist that finishes.

This problem doesn’t seem to be caused by MoB: I tried revisions prior to it and the glitch was present (confirmation of this wouldn’t hurt though).

Closed by  Nicolas Pennequin
2008-07-08 15:07
Reason for closing:  Out of Date
Steve Bavin commented on 2008-03-17 17:42

Is this still a problem? I used to have a start glitch sometimes, but not with recent builds.

Nicolas Pennequin commented on 2008-07-08 15:07

The recipe was originally tested on a Gigabeat F.
I couldn’t reproduce it on an iPod 5.5G with a recent build and apparently no one else has either.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing