Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Dmitri - 2007-11-09
Last edited by Jonathan Gordon - 2008-10-22

FS#8124 - Playback resumes when shutting down after pause and ff/rew

Gigabeat resumes playback for a short period of time when shutting down if the player is currently paused.

To recreate:
1. Play a track partway through
2. Pause the track with the 'a' button
3. Rewind to the beginning so that the track will play from the beginning when turned on next time.
4. Shutdown the player

While the "Shhutting down" text is displayed, the trac will start playing again until the gigabeat turns off completely. However, when starting up again, playback resumes from the very beginning, as expected.

The issue is minor, I guess it's just a little odd that the player start playing again. I assume the shutdown code toggles play/pause instead of stopping playback.

SVN version r15515-071107

Closed by  Jonathan Gordon
2008-10-22 10:00
Reason for closing:  Fixed
Additional comments about closing:  

fixed in svn

Steve Bavin commented on 2007-12-11 17:22

Happens on H340 too. The rewinding is important.

Jonathan Gordon commented on 2008-06-24 02:18

this is still an issue… and its not related to "fade on pause" (having that set to yes or no still causes it)

Michael Chicoine commented on 2008-07-01 00:52

This also happens on sansa e200 with svn r17902-080630. Some time back, it stopped happening on shutdown. Now, it only happens when the stop (menu/power) key is pressed and the track has been paused and rewound to the beginning. I have also noticed that if you press stop while on the main menu, the playback starts right after the menu changes from "Now Playing" to "Resume Playback".

Michael Chicoine commented on 2008-07-01 04:27

After further testing with a clean install, the sansa e200 does still resume playback when shutting down as described above. The other observations in the previous comment are still valid.

Marc Guay commented on 2008-07-13 01:34

Confirmed w/ e200 & r18013. Fast-forwarding has the same effect. The key is to have paused, moved the playback point using FF/REW (not prev-track/next-track), and shutdown before resuming playback.

Jonathan Gordon commented on 2008-10-19 10:15

ok, trrying to track this down and it looks like that you dont have to shut down to see the problem…. pause playback, ff/rwd then stop and it will start again. This happens in the sim also so hopefully it is traceable

Jonathan Gordon commented on 2008-10-19 10:38

ok, I tracked this down :D
I havnt done much testing so I dont know if this causes any odd sideeffects… (I dont think it will because the only thing it changes is 1 call to pcmbuf_pause() which happens about 4 times between pressing STOP music actually stopping)

Michael Chicoine commented on 2008-10-19 18:03

This appears to correct the problem (at least on my e200).

Michael Chicoine commented on 2008-10-19 19:00

This appears to correct the problem (at least on my e200).

Jonathan Gordon commented on 2008-10-20 07:23

… I was hoping one of the playback guys would look at this and decide to either commit this, or try and fing the real reason why ffw/rwding acts up…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing