FS#8125 - Inconsistent scale in color selection

Attached to Project: Rockbox
Opened by Dmitri (DiscoSuperstar00) - Friday, 09 November 2007, 17:49 GMT
Last edited by Tom Ross (midgey34) - Friday, 09 November 2007, 17:56 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Color selector has different scales for colors. Specifically, the red and blue scales range from 0-31 and the green scale ranges from 0-63.

Seems like these scales should be identical, preferably 0-63 for the 16bpp targets.
This task depends upon

Closed by  Tom Ross (midgey34)
Friday, 09 November 2007, 17:56 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  See my comment
Comment by Tom Ross (midgey34) - Friday, 09 November 2007, 17:56 GMT
On our color targets, the pixel format is RGB565 (or swapped). This means 5 bits for red and blue and 6 bits for green so the range for red and blue is 0-31 (00000 - 11111) and the range is 0-63 for green (000000 - 111111). The ranges are exactly as they are supposed to be and should not be changed. This is not a bug.