Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bookshare - 2007-11-14
Last edited by nls - 2008-12-02

FS#8153 - chinese-simp and chinese-trad do not speak

When I make a voice file in chinese, both simp and trad, I always get spelled out english in a chinese accent, which is usual behavior for chinese synthisisers. I investigated and found the <voice> strings were filled out in english. Could this bug be fixed? Thanks.

Closed by  nls
2008-12-02 13:47
Reason for closing:  Invalid
Additional comments about closing:  

This is not a bug but an incomplete translation or at best a feature request.

Project Manager

Here is an excellent opportunity for you to help out. Please update the <voice> strings for us and submit a patch.

Yes the voice string is just a copy of the english string throughout both translations. I was thinking of changing that, but I was not aware of any chinese voice synthesizers, so I never get around to do that. But it should be an easy task, though, just use some text processing tool (thinking regex might work) and “paste and copy”. I can probably do it after all my school loads are gone (i.e. after finals).

I made 8132. And just incase anyone is interested the synth is neospeech.

I’ll do it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing