Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by petur - 2007-11-15
Last edited by nicolas_p - 2007-11-26

FS#8160 - skip back after resume fails to play the song again

To reproduce:

- Be at about 10 seconds from the end of a song
- Stop and powerdown
- power up and resume playback
- skip back to start the song again

after some seconds playback skips to the next song automagically

Closed by  nicolas_p
2007-11-26 21:07
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#8092 

This looks like a duplicate of  FS#8092  to me.

petur commented on 2007-11-15 09:20

I did look at it before submitting this one, but went ahead anyway because it talks about seeks, not a plain skip back.

If it is a dupe, it just shows I know nothing of playback/buffering. I added 8092 as related task….

I think this is a dupe of an even older bug having to do with _seek_ behavior when the codec has finished but the pcm buffer is full.

I’m experiencing this, too, just a little more detail.
to reproduce (with 15722)
-play an MP3 (FLAC seems to work, too) for a while, stop
-resume
-after the buffer has been filled, skip back to the beginning of the track
-Track won’t play to the end.

The time it stops before the end seems to be approximately the same as the time elapsed when the initial stop was done.
As noted, both FLAC and MP3 have this problem, MP3 will just go on to the next track while FLAC will get stuck playing a sample repeatedly at the breaking point.
AAC seems to be immune.

From the reproduction recipes, I’m 99% sure this is a duplicate of  FS#8092 . I’m committing a fix for  FS#8092 , so reopen this if the fix didn’t solve the problem described above.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing