Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iriver H10
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Alexandre Fournelle - 2007-11-16
Last edited by Michael Sevakis - 2009-01-30

FS#8170 - Screendump function broken, makes usb plug/unplug detection hang

The screendump function in the debug menu doesn’t work. When plugging in the usb to trigger the dump, there is no disk activity and no bitmap creation. Moreover, the usb detection seems to get borked too, with the status bar reporting usb detected and battery charging even when the cable is unplugged.

r14599 (early september) seems to be the last good svn revision.
r14600 commits introduced the bug.

To reproduce, just follow usual screendump procedure :
- system → debug → screendump
- plug the usb cable
- unplug the usb cable

Unsure whether it affects other PortalPlayer devices.

Closed by  Michael Sevakis
2009-01-30 02:45
Reason for closing:  Fixed
Additional comments about closing:  

The USB screendump function now overrides all user input or modes when turned on.

Dave Chapman commented on 2007-11-16 16:59

I've investigated this, and it appears to be a H10-specific problem.

The screendump is only performed when the USB code receives the USB_INSERTED event. On the H10, the normal Rockbox USB logic is reversed, so the USB_INSERTED event only happens when holding RIGHT when inserting USB. Otherwise, a USB_POWERED event will be sent.

I'm not sure how to fix this, or if we even want to. Maybe just wait until the Rockbox USB stack is working…

Jonathan Gordon commented on 2008-11-16 11:57

"On the H10, the normal Rockbox USB logic is reversed, so the USB_INSERTED event only happens when holding RIGHT when inserting USB. Otherwise, a USB_POWERED event will be sent." if that is the case then I tihnk the correct fix is to change that to be consistant with every other target.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing