FS#8180 - maze game causing freezing on sansa e250

Attached to Project: Rockbox
Opened by Andy Zobro (xobes) - Sunday, 18 November 2007, 06:35 GMT
Last edited by Marc Guay (Marc_Guay) - Tuesday, 01 April 2008, 01:23 GMT
Task Type Bugs
Category Games
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Prefetch abort
at 656C6966 (0)

when game "maze" selected for the first time.

opened up disconnected battery.

started up, first thing went and tried to see if maze would do the same thing.

played maze for a few seconds and decided to tray another game.

when attempting to play jewel, the screen said loading and i could not get back to menu, disconnected battery again (this time it was the normal loading screen, no prefetch message this time.)
started up again, started a song this tie, then went and started jewel. played jewel for a few moments and decided to try another game. played jackpot for a few moments and decided to try maze again. started maze, played for a few seconds, and decided to return to the menu. attempted to start jackpot again only to find that the loading screen showed up, music kept playing, game didn't start, no response to buttons, pulled battery again.

It seems to me that there is something wrong with the maze game in rockbox build r15607-071113 that causes freezes either on entry into maze or the next thing after maze.

I have not tried in the latest daily build, and i did not find any other bugs about "maze". I have not seen this behavior in any other plugins. I am a new rockbox user and the version I have listed above is my first and only version, I do not know when this problem was introduced.

Since it required removing the battery, I would rate this bug pretty severe.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Tuesday, 01 April 2008, 01:23 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Tried to reproduce w/16899 and could not. Seems like a random case.
Comment by Bertrik Sikken (bertrik) - Thursday, 22 November 2007, 09:30 GMT
There's no need to remove the battery. Holding the 'power off' button for about 15 seconds (or maybe a little longer) should power off the device, even when the software is completely frozen. Interestingly, the prefetch abort number spells 'elif' in ASCII, or 'file' backwards.