Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PaulJam - 2007-11-19
Last edited by jdgordon - 2008-06-29

FS#8187 - Charging from USB breaks sleep timer

When the sleep timer is set and the device is charging via USB then nothing happens when the countdown reaches 0:00. Playback continues and the timer continues to count down (the %bs WPS tag returns negative values like -12:-34).
As soon as the USB calble gets disconnected the device shuts down.

While charging from the normal A/C adapter everything works (more or less*) as expected:
When the countdown is over playback stops and the backlight/screen turns off.

The problem was reported on IRC for an Ipod (no exact model mentioned) and was reproduceable on an H300 with r15682.

* - There is a delay between the timer reaching 0:00 and the device actually shutting down (i experienced ~30 seconds delay with a 2 hour sleep timer) but this is not a big issue.

Closed by  jdgordon
2008-06-29 09:44
Reason for closing:  Fixed
Additional comments about closing:  

patch worked… commited

I can confirm this behavior on e200 as well.

The issue seems to be at line 545 of current SVN's (r16309) firmware/powermgmt.c:
if(sleeptimer_active && !usb_inserted())

Removing the usb_inserted() condition allows the sleep timer to trigger and stop the audio (I believe pp502x devices should stay powered on while the charger is inserted).

I'm definitely not very familiar with rockbox code or all the platforms it supports, so I don't know (and rather doubt) that removing that usb_inserted() condition is the correct solution, or whether the logic within the function itself leads to the endless countdown.

they obviously had a reason to put that there so maybe that check needs to be expanded to include a device check for those players that can't be shut off while charging. I also noticed that I can't turn off my e200 while it's plugged into usb; is this caused by that same line of code as well?

If it matters, the wife of this e200 owner would like the sleep timer to at least stop playback.

Me, I'm more worried about the battery over charging.

this should fix it… please test it out

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing