• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by DimensionSix - 2007-11-20
Last edited by roolku - 2007-11-22

FS#8196 - Gather Runtime Data > User Rating not working

The Gather Runtime Data function works again since yesterday or something but I can’t get the rating to work.
When I rate songs, the rating is saved so I can view it in the rating menu. But the database doesn’t show the ratings. Also after reboot, there are still some of my ratings but the ones from tracks at the very beginning of the playlist are set to “0”. I don’t know if WPS show the rating because I don’t have one with rating display installed.

Also, I imported the Runtime Data from some time before. There were two rated tracks which show up in the database. But if I play them and change the rating, they disappear from the database.

I don’t know if this only occurs on H3xx or only on my player so please tell me if you have got the same problem.

Tried this with the latest build (r15722).

Closed by  roolku
2007-11-22 22:23
Reason for closing:  Fixed

Hm, this does not happen in the gigabeat sim, although I have noticed it on target. Will try to investigate further if I find some time.

This might be fixed in r15748, could you confirm?

No sorry. It doesn’t work for me. Downloaded the latest build, resetted my settings, enabled Gather Runtime Data und intialized the database. After reboot the database gathers runtime data but my ratings aren’t saved.

Hm, it works in the gigabeat sim - I’ll try clean svn on target now.

From your description it seems you don’t load the database to ram? Could you test if that makes a difference?

I’m sorry. I forgot to mention this. I had loaded it to ram.

I can’t replicate this on gigabeat with fresh svn, dircache on, reboot, load to ram, gather run time data, initialise. Play one song, set user rating, check database → track is filed under the correct rating, reboot, track is still filed under correct rating. Export database, track is in there with correct rating. What are you doing differently?

I installed now a “clean build” and did exactly what you described. After rating the song the icon for hdd activity is displayed but the rating isn’t listed in the database.
Could it be that this problem is H3xx specific? I’ll try this on the H10 of my brother later.

I tried this now on the H10. Everything works perfect there.

Thanks for that. I have now found the problem and will commit a fix as soon as there is no red in the build system anymore.


Available keyboard shortcuts


Task Details

Task Editing