Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bertrik - 2007-11-21
Last edited by bertrik - 2010-10-10

FS#8208 - Distortion on some tracks

I’m experiencing some kind of crackling effect on some tracks.
The same track sounds clean on the PC and on the OF (on the same headphones).

Things I already tried:
* turn down the volume → still crackles at -40 dB
* convert track from mp3 to wav, no effect
* various settings in the AS3514, like enabling/disabling ZCU, HPCM, AGC, bias current reduction with no positive effect. I also tried to set the AS3514 to as-default-as-possible settings and that didn’t work either.
* reversing the roles of headphone volume and DAC volume (which of the two is increased first when increasing total volume), no help either.

The current SVN version (15741) still has it. I tried going back to find out which revision caused it, but even version 15000 already had it. I tried going back to even older versions, but I’m having some trouble compiling them.

Attached is a small clip in which I experience the distortion, it’s noticeable between second 2 and 3 and at second 7 (compressed with flac for file size reasons).

   clip.flac (867.9 KiB)
Closed by  bertrik
2010-10-10 09:23
Reason for closing:  Wont Fix
Additional comments about closing:  

Issue has been documented in the wiki (SansaFAQ). Cause is still unknown.

MikeS commented on 2007-11-22 17:37

You’ve turned off all DSP effects in rockbox? I can’t hear a problem myself unless forcing what should be clipping (and I might hear wrapping noise).

Yes, I still hear it with all settings to default (no eq, no bass, no treble, no cross-fade, no cross-feed).
I tried to reproduce it with some synthetic sine waves of -6, -3 and 0 dB without success.

MikeS commented on 2007-11-22 19:07

That’s odd that a 0db sine wave would be ok. Couldn’t be wrapping in the i2s bus then since that would surely show it.

I just wiped my .rockbox dir and installed a fresh copy to be sure.
Maybe I should record it through my soundcard and have a look at it in an audio editor.

Attached are my test tones.

r15873 fixed a clipping issue if dithering was enabled, don’t suppose this was the problem?

r15966 still has the problem. Never used dither (I think the sansa already implements this in hardware anyway).

Attached is a recording of the same clip from the line-in of my sound card, the sansa volume was set at -10 dB. The clip was recorded using audacity under windows xp and normalised afterwards to -3 dB.

I see discontinuities on the left channel at 2.555 and on the right channel at 2.548, 2.549 and at 2.554. When looking in spectral view at these artifacts, the normal music does not have any frequency content above 17 kHz or so (from being an mp3 originally), while the discontinuities show broad spectrum noise up to 22 kHz.

MikeS commented on 2007-12-29 07:41

This isn’t clipping noise but wrapping noise and quite likely not bus-related overflow noise since it switches channels as I previously speculated.

Two things you’re not going to want to hear:
1) The problem is worse the lower the volume which could be masking effects but the profile of the sound as volume changes doesn’t match that too well.
2) The problem is far, far worse in the original firmware than in rockbox. (definitely confirmed on my device) It exhibits the same inverse relationship with volume.

During IRC discussions, MikeS discovered that the problem can be greatly reduced by enabling the equaliser (with flat response) and applying some precut.

Is this bug still valid?

As far as I know, there has been no explicit attempt to fix this. Some changes were made for the HPCM common mode output of the AS3514 codec, there’s a very small chance that it affects this problem. I’ll check if the problem is still there sometime this week (please remind me if I forget).

At some point we may just have to conclude that it’s a hardware problem that rockbox cannot do anything about, document that fact and close this task. I still like to have at least a bit more insight about where the problem originates (e.g. at what point in the signal chain does it start, is it an analog or a digital artifact?).

The problem is still here (in svn r24036). I did some experiments with the as3514 settings again (HPCM, various bias settings, headphone overcurrent setting, LRCK clock settings). Unfortunately it resists any attempts from my side to make it better or worse.

I plan to document this problem on the wiki (with a link to here) and then close this task within the next week or so.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing