FS#8218 - Playback stops when metronome starts

Attached to Project: Rockbox
Opened by harry tu (bookshare) - Saturday, 24 November 2007, 19:13 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 25 November 2007, 10:37 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I start the metronome, music playback stops. You said that music playback could run concurrently with plugins. Thanks.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 25 November 2007, 10:37 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  yes, music can run when plugins are running... but only if the plugin doesnt need to audio hardware (or the pcm buffer)
Comment by Michael Sevakis (MikeS) - Saturday, 24 November 2007, 21:28 GMT
No, it can't since it uses the PCM hardware directly. Metronome could use the voice channel but the plugin would have to be converted to pass a continuous stream (including sending silence between long ticks) over to the pcm buffer rather than relying solely on a timer and pcm_play_data to do everything. Relying on mixing to get it there without alot of jitter if naiively sending the tick clip will be frustrating.
Comment by harry tu (bookshare) - Sunday, 25 November 2007, 02:28 GMT
But chessbox works fine. I can hear the forster sisters while playing chess.