FS#8258 - Disk Spinning While Playing Music

Attached to Project: Rockbox
Opened by Nate Rowe (Spanky) - Saturday, 01 December 2007, 02:33 GMT
Last edited by Steve Bavin (pondlife) - Monday, 03 December 2007, 11:05 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When starting a song my hard drive will spin up to load the song and it never seems to spin back down. Even after 5+ minutes of music listening. It's almost like the iPod is playing the music directly off of the Hard Drive itself instead of loading it into memory. I ran my iPod through all the tests that it has and everything was fine. If I pause the music and go to the menu, after about 8 seconds the Disk will stop spinning and I can resume the music without it spinning back up.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 03 December 2007, 11:05 GMT
Reason for closing:  Not a Bug
Comment by Nate Rowe (Spanky) - Saturday, 01 December 2007, 02:36 GMT
I should have added that after I can make the Disk stop spinning it will go through 3-4 songs before it will start the spinning thing again. It's pretty annoying and I don't want to damage the hard drive while it is spinning with g-forces and whatnot.
Comment by Mdkart (Mdkart) - Sunday, 02 December 2007, 10:41 GMT
What is your setting for the Anti Skip Buffer (General Settings -> Playback -> Anti-Skip Buffer)?
Comment by Nate Rowe (Spanky) - Sunday, 02 December 2007, 23:07 GMT
It is set to 5 seconds.
Comment by Mdkart (Mdkart) - Monday, 03 December 2007, 08:56 GMT
You can increase this setting to 3 min for example. Extract from the manual of rockbox :
"Anti-Skip Buffer
This setting allows you to control how much music is stored in the
player’s memory whilst playing a song, acting as a buffer against shock or playback
Comment by Nate Rowe (Spanky) - Monday, 03 December 2007, 09:11 GMT
It's not being shocked at all. It's setting on my desk or the arm of my chair, not moving or anything. I have no clue what is going on. It seems to stop spinning after about 40 seconds within first loading a song. It seems that it should stop spinning after 20 seconds because I wouldn't think it would take that long to load the next songs. In any way it doesn't look like it is acting up anymore. I request this to be closed, if I have this problem again I will make a new post. Thanks.