Rockbox

Tasklist

FS#8293 - PictureFlow bug report

Attached to Project: Rockbox
Opened by Chris Kotulla (chrissel) - Monday, 10 December 2007, 13:56 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Monday, 10 December 2007, 16:19 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hey guys,

first of all you did an awesome job. It's nice to have a coverflow on a nano 1G. Of course this plugin isn't perfect yet e.g. if you change or replace the album art image the plugin won't recognize this. It still displays the old image. Because you haven't implemented the "bmp resize patch" (yet) the plugin uses only the small images used for the WPS. That's very uncomfortable for my nano because I use a 65x65 AA WPS and it would be nice if the plugin could display bigger ones.

For the future: Would it be possible to implement a tracklist and/or the possibility to start a track from within the album art "display"(Like the new iPods do)?
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Monday, 10 December 2007, 16:19 GMT
Reason for closing:  Not a Bug
Comment by Thomas Martitz (kugel.) - Monday, 10 December 2007, 16:10 GMT
Is it intended, that I have to turn the wheel counter-clockwise on my e200 to get to the next album art? It's kinda weird.

I might add, that we need scroll wheel acceleration. I need to turn the wheel for more than 15 s to scroll through my approx. 100 albums at highest speed. Not to mention that my thumb hurts afterwards.
Comment by Nicolas Pennequin (nicolas_p) - Monday, 10 December 2007, 16:11 GMT
This is more of a wishlist than a bug report. It's a bit premature considering the feature has only just been committed. I'm closing this task, but first I'll address your concerns:
* To display bigger bitmaps, use cover.100x100.bmp files. They will be used instead of the 65x65 ones.
* Displaying a track list and starting playback from there are planned features.
Comment by Thomas Martitz (kugel.) - Monday, 10 December 2007, 16:15 GMT
"if you change or replace the album art image the plugin won't recognize this"
I'd consider this as a bug.
Comment by Nicolas Pennequin (nicolas_p) - Monday, 10 December 2007, 16:17 GMT
kugel:
No, the e200 behaviour wasn't intended. Neither I nor jott own a sansa, so we couldn't really know about that issue. We'll see what we can do without affecting other targets.
Scroll acceleration is a different and much more complex matter. We're probably not going to reinvent it just for the plugin, so if it's not accessible to plugins, I guess we're out of luck. If it is we'll add it.
Comment by Nicolas Pennequin (nicolas_p) - Monday, 10 December 2007, 16:18 GMT
"if you change or replace the album art image the plugin won't recognize this"
--> that part didn't exactly stand out in the middle of all the requests... However it is a simple consequence of the caching. There is now a menu option to trigger a cache rebuild.

Loading...