Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by overfault - 2007-12-14
Last edited by nicolas_p - 2008-01-13

FS#8324 - Problems with FLAC playback

1. Playing APE with halts every 2-3 seconds, meanwhile infinitely.

2. Both APE/FLAC: sometimes during playback when press pause starts “…seeking…” infinitely.

Files are not fragmented.

iPod Video 5.5G 80GB
r15908-071210

Closed by  nicolas_p
2008-01-13 15:42
Reason for closing:  Not a Bug
Additional comments about closing:  

APE problem is not a bug. See  FS#8260  or  FS#8296  for the playback skipping issue.

sorry, some fault
1. Playing APE with halts every 2-3 seconds, meanwhile “…seeking…” infinitely.

1. Is to be expected: APE is very processor intensive and the iPods are rather slow (see http://www.rockbox.org/wiki/SoundCodecMonkeysAudio)

I don’t understand the second issue, could you please be a little more descriptive?

sorry, some fault
1. Playing APE with halts every 2-3 seconds, meanwhile “…seeking…” infinitely.

– Friday, 14 December 2007, 12:53 GMT
ups.. duplicate

– 1. Is to be expected: APE is very processor intensive and the iPods are rather slow (see http://www.rockbox.org/wiki/SoundCodecMonkeysAudio)
Is there some way to optimize APE decoding?

– I don’t understand the second issue, could you please be a little more descriptive?
Playing FLAC, then press ‘play/pause’ to pause playback. Playback stops and sometimes player starts “…seeking…” intensively for some minutes, I cannot stop this beacause keys not responding.

p.s. sorry for my bad english

APE is CPU-intensive because of how it was designed. It was never really meant to be used on limited embedded devices. You should convert your files to another format, as it is very unlikely that APE will ever be fast enough on the iPods.

What do you mean by “seeking”? Is the disk seeking? (or spinning, maybe?)

– You should convert your files to another format
I’ve converted all my APE’s into FLAC - works fine, problem solved, thanks.

– What do you mean by “seeking”? Is the disk seeking? (or spinning, maybe?)
Yes, I mean intensive disk reading(spinning). “…seeking…” - this was a string from Mixtape theme.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing