Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Gerhard Dirschl - 2007-12-23
Last edited by Peter D'Hoye - 2008-08-22

FS#8362 - S/PDIF recording is not working with certain input devices

The current rockbox build failed to record from a 16Bit 48kHz source (via optical in). The sampling-rate is recognized correctly. The peak-meter and analog monitor is also working. But when I press the play button to actually start recording, not much happens. The “recording” icon and the destination filename is displayed and that’s it. Time and byte counter stay 0 and the destination file is also not created.

Closed by  Peter D'Hoye
2008-08-22 22:32
Reason for closing:  Fixed
Additional comments about closing:  

fixed recently by amiconn: the valnogood bit is now ignored

Peter D'Hoye commented on 2007-12-23 23:56

did you try starting recording with REC?

Gerhard Dirschl commented on 2007-12-24 09:39

I did, but I got the same behavior. I should have noted that this only happens when using the digital (S/PDIF) input. Recording from the internal microphone, analog input or FM Radio works without any problems.

Michael Sevakis commented on 2007-12-24 10:39

When _exactly_ did that break? Only the current build? It surely worked fine last time I checked it.

Michael Sevakis commented on 2007-12-24 11:12

Just confirmed this. Weird. I’ll have a look-see.

Michael Sevakis commented on 2007-12-24 11:26

Nix that. I forgot that it won’t actually receive samples without an actual sigal source (time remains at 0) so I went and actually plugged my H120 into a DVD unit with optical out and it recorded that just fine.

Gerhard Dirschl commented on 2007-12-25 12:03

That’s weird. It seems to be an incompatibility between rockbox and my DVB-S receiver. I did some more testing:
- DVB-S box and rockbox (16Bit @ 48kHz): cannot record (peak meter and analog monitor is working, though).
- DVB-S box and iRiver-Firmware (16Bit @ 48kHz): works.
- CD-Player and rockbox (16bit @ 44kHz): works.

Gerhard Dirschl commented on 2007-12-25 12:12

I just remembered that there’s a S/PDIF analyzer in the debug menu:
Val:– Sym:OK Par:OK ←– uh, oh
Status word: 20000840
Pro: 0 (Consumer)
Audio: 0 (PCM)
Copy: 1 (Permitted)
Preemph: 4 (Reserved) ←– hm?
Mode: 0
Category: 0×00 (General)
Generation: 0 (No ind.)
Source: 0
Channel: 8 (A (Left)) ←– ??
Freq: 4 (48 kHz)
Clock accuracy: 0
Measured freq.: fluctuates between 77xxx-80xxx Hz ←– what the…

Gerhard Dirschl commented on 2007-12-25 12:26

One last note. I recorded a few minutes from the DVB-S box with the original firmware. The WAV file (16Bit, 48kHz, Stereo) sounds OK.

Michael Sevakis commented on 2007-12-26 04:12

The fact that you are getting peakmeters and monitoring (which is digital) along with a sticking recording is really weird since data would have to be received for peaks to be calculated and monitoring to be heard which should just be buffered and encoded like anything else. Any chance of trying with a logf build, dumping that and posting it here?

Gerhard Dirschl commented on 2007-12-29 00:11

Did it (with logf enabled globally).
I plugged in the TOSLINK cable,
entered the recording screen using the REC-button,
started recording with REC,
waited a few seconds and started a new file with REC,
stopped recording after a few more seconds,
exited the recording screen and called logfdump.

   logf.txt (30.1 KiB)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing