Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System iPod 1G/2G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by uteck - 2007-12-25
Last edited by speachy - 2024-04-21

FS#8372 - Idle Poweroff only reboots my 1G iPod

The Idle Poweroff only reboots my 1G iPod. I assume it should power it off or put it into a power saving mode. This forces it to use up the battery faster then normal unless I set the Hold button to boot into the iPod firmware to do a proper suspend when Rockbox reboots.

Closed by  speachy
2024-04-21 12:54
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

These tasks are _very_ old and most likely long since fixed. Please retest and open new tickets if they are still relevant.

Have just loaded Rockbox to my 2nd Gen iPod and have experienced the same problem. When ever the iPod shuts down, either manually or auto power off the apple logo is displayed and then it restarts.

Noticed in the iPod 5G too, the only thing I really miss from the native firmware is the quick response from the 'suspend' mode.

That's a known effect. 1st and 2nd Gen iPods cannot be physically powered down, but only put into suspend. Rockbox doesn't support that yet.

The recommended workaround atm is to disable idle poweroff, so it doesn't reboot unexpectedly. If you want to "shut down", press Play until rockbox shows the "Shutting down…" splash, then flip the hold switch. This will cause the bootloader to load the OF, which will in turn put the iPod into suspend after a short while.

I've done this but have found that whenever I power the iPod back up I get the old Apple firmware, unless I start it up by pressing Menu and Play simultaneously, which boots back to Rockbox. Is this the expected behaviour?

yes, because the apple firmware doesn't reboot the Ipod but puts it into a low power mode instead. Thus "powering up" the Ipod again will still be in the Apple firmware.

I'm marking this as 3.0 so that it is either well-documented or disabled for the release.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing