Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mash - 2008-01-03
Last edited by Marc_Guay - 2008-07-08

FS#8394 - iPod Video regularly crashes

(thought of updating rockbox on my ipod video 5g after reading the promises of extended battery life in changelog, however)
using current builds (tried 2007-12-31/2008-01-02) results in rockbox playback regularly crashing (after minutes to half hours) with some
“undefined instructions at 00069470”
(or: 00069440 or whatever - subject to change)
the (evilG)build from september I am normally using still works fine in same setup ..

Closed by  Marc_Guay
2008-07-08 03:49
Reason for closing:  Out of Date
Additional comments about closing:  

Please reopen if this is still happening, though I doubt the most-used target could have such a serious issue and this is the only noise that's made.

Project Manager

It sounds like this is triggered by certain songs on your player. Would it be possible for you to identify which song that causes Rockbox to crash? It is likely to be one of the few songs right after the one you are playing when it crashes, or sometimes even the song that is playing.

Not too sure I agree nielsen… had similar troubles, even after a fresh boot and navigating files. Appears random, as I get similar errors playing a FLAC album, but not every time I play the album.

just loaded today’s build, not sure that anything will be different though.

mash commented on 2008-01-05 02:10

It does not seem to me like a problem with certain files also - more like “random”. rebooting the player, continuing where it crashed (most likely the song played before the crash) it plays fine over the song where it crashed and a few others before it crashes again …

Project Manager

Ouch. Badness. Then I have no more good theories… :-(

Hi Michael,

Would you be able to try some old builds out to see on which date (and at which change) the crashes started?

This can be tricky if the crashes are intermittent, but if you can pretty much guarentee a crash after (say) 5 tracks, then it’s very useful information.

By far the best way to access older builds is to set up a build environment and use SVN. Then you can perform a binary chop to narrow down to a particular revision.

I’ve seen this issue as well with revision 16165 (08-01-25). I’ll have to see if i can find the regression, but unfortunately, this is not my most common crash. Revision 15548 (2007-08-09) didn’t have this problem, or the other crash for that matter. Huh…while I was typing this, I got one of the crashes described here:

Undefined instruction
at 00068C44

Just to be clear, this is on revision 16165.

I may have a problem file. My iPod video has now crashed 3 times total with the previous error and this one twice on a single song.
Data abort
at 40001538

It is a FLAC rip from one of my CDs. If you want access to the file for testing purposes, let me know. I’ll post it somewhere or upload to your server of choice.

Just as a mental note for me, the track is “Max Graham feat. Jessica Jacobs - I know you’re gone” from Armin van Buuren’s A State of Trance 2005 CD1.

I’m sorry, the correct revision for the 2007-08-09 checkout was 14251, not 15548 as previously stated.

Sorry for the junk in here, my bug seems to be a different one that was introduced after you posted this bug.

Hi, I experienced this problem too… I use r16536-080306 with ipod 5.5g 30gb.
My song format is MP3, M4A, FLAC, and MPC.

It always happens randomly, usually crashed in 30 minutes to 1 hour play.
What revision is known to not have this problem?
So maybe, someone can look into the code from that revision to current one.
Thanks.

Same crashes here.

I noticed crashes while playing music in background and browsing/selecting files in foreground.
Sorry, no more hints :-(

Thanks for your work!

Sebastian, which bootloader version and build number are you using?

I used RockboxUtility (last Saturday, Version 1.04) to install the complete system.
After that, i copied Rockbox Version r16989-080406 onto the ipod video 80gb.

Sorry, i am here at work w/o the usb cable.
Where could i find the bootloader version ?

Turn on your iPod and then hold the »| button as it boots. The bootloader version is displayed on the second line of text on the boot screen.

Found it, thank you Michael!

Bootloader Version is 2.0

MikeS commented on 2008-04-08 20:04

I Rockboxed my sister’s 30Gig in about 5 minutes yesterday and had no problem. I installed manually.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing