Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Petter Sundlöf - 2008-01-06
Last edited by sideral - 2011-05-19

FS#8414 - Duplicate entries in database (not caused by trash folders)

Using r15994.

I’ve lately been having a lot of issues with the database creating duplicate (mostly double but some times three or four repeats of the same song) entries for identical files. This usually happens after one or too reboots/powerdowns. These are not caused by stray .Trash, .Trashes etc

I have repeatedly tried deleting all my .tcds in .rockbox/ and recreating the database.

I’m attaching my .tcds and an example playlist (analord11.m3u8)

Closed by  sideral
2011-05-19 15:20
Reason for closing:  Out of Date
Additional comments about closing:  

No confirmation whether the problem still exists.

Lee Kang Hyuk commented on 2008-01-07 14:47

This happened to me when i renamed the files, or changed the paths.
I guess i found a solution. Please check  FS#8423 .
You may have to ‘Initialize Now’ to clear the duplicated entries.

Petter Sundlöf commented on 2008-01-07 14:50

I don’t see how that’s related – your bug seems to pertain to files that are no longer there?

Lee Kang Hyuk commented on 2008-01-08 09:52

When renaming files, its entries are deleted at first. In this case the file’s title field could be no longer in use. This is why i thought it a same thing.
Does it occured when you did altered nothing? Please let me know if the latest build does not solve your problem.

Petter Sundlöf commented on 2008-01-08 10:00

I’ve not altered any files, not even added any.
And still, after one reboot, there are duplicate entries everwhere, a few triple entries.
Also, a new behaviour I’ve witnessed with recent firmwares is that it will do a “Searching…” on entering almost any album/place in database. This considerably slows down navigation.
I will try the latest firmware now.

Lee Kang Hyuk commented on 2008-01-08 15:38

Slow browsing is normal behaviour with ‘Load DB into RAM’ not enabled.

Giles commented on 2008-01-09 13:24

I also get duplicate entries for iPod5G but only when Auto Update is set to YES.

It’s happening with release r16027 and for previous releases since Dec 2007.

Miika Pekkarinen commented on 2008-01-22 17:14

I think this has been now fixed. Please re-open the task if problem still happens.

Giles commented on 2008-02-28 17:37

can’t reproduce in r16441, looks OK now.

Steve commented on 2008-03-02 00:28

I’m still seeing this problem using r16460 on my c200. It seems to be related to booting in to the OF. After several sessions with RB, I connected the USB and booted into the OF just to charge the battery (because I didn’t know I could charge only from within RB). When I disconnected the OF did the usual “Refresheing Database” message. When it completed I powered off and then booted into RB. When it came up I immediately checked and found every entry in the database had a duplicate.

Marc Guay commented on 2008-03-10 18:28

Sansa e200 + r16601 + Database Initialized + Auto Update On. Booted into Sansa firmware, let it refresh the database, went back to Rockbox, database contains single entries.

Lee Kang Hyuk commented on 2008-03-11 01:44

Hard to figure out when and why, and hard to reproduce, but I can sure duplicated entries problem still exists.
This problem seems to occur only when ‘Load DB into Ram’ is disabled.
If I’m not wrong, it seems that database_tmp.tcd does not erased at proper time.(due to a low voltage, immediate power down during boot-up, or whatever)
As a result of that, entries may committed twice.
This could happen in Sim too. Try kill simulator window while large amount of entries being committed.

David Banks commented on 2008-07-23 17:44

I have also experienced this problem with a Sansa e200, r17826.
It seems to affect random files in the database, since only about half my collection gets duplicated.
Running ‘Initialize Now’ always fixes it, but also erases the history, which sucks.

I did two things recently before the problem started: 1, started syncing my music with rsync, rather than copying the entire folder every time (don’t laugh); 2, enabled ‘Gather Runtime Data’. So maybe it could be related to one of these.

Eddy commented on 2008-07-25 08:10
Running ‘Initialize Now’ always fixes it, but also erases the history, which sucks.
Use the ‘Export Modifications’ functionality, which writes all the runtime data to a flat file that can then be re-imported once you’ve initialised.
Steve Bavin commented on 2008-07-25 09:12

I’d like an Initialise Now that did the Export/Import stuff automatically… but I guess if Updata Now worked in all cases then this (and indeed Initialise Now itself) would become unnecessary.

greennick commented on 2008-10-17 21:13

This is still happening for me with Rockbox 3.0 (r18821-081016) on a 1st generation iPod Nano. All songs appear in the database 8 (eight!) times, and database initialization is slow. If I delete the files (through Amarok), the database entries finally vanish and initializing the empty database (with NO song files loaded) hangs on one screen forever (”Building Database…4121 found”). When I load new songs, it asks me to initialize the database (and I oblige), but it immediately “finds” 8 copies of each song, although they’re only on there once.

I’ve tried deleting all database files (.rockbox/database*), it seems to make no difference.

I was hoping Rockbox 3.0 would solve this (I had the same problem with an August build, but this problem did NOT exist on my previous old build) Any ideas? I might have to try down-grading rockbox versions, since I didn’t have this problem a year ago - that would be lame.

greennick commented on 2008-10-17 23:52

This is still happening for me with Rockbox 3.0 (r18821-081016) on a 1st generation iPod Nano. All songs appear in the database 8 (eight!) times, and database initialization is slow. If I delete the files (through Amarok), the database entries finally vanish and initializing the empty database (with NO song files loaded) hangs on one screen forever (”Building Database…4121 found”). When I load new songs, it asks me to initialize the database (and I oblige), but it immediately “finds” 8 copies of each song, although they’re only on there once.

I’ve tried deleting all database files (.rockbox/database*), it seems to make no difference.

I was hoping Rockbox 3.0 would solve this (I had the same problem with an August build, but this problem did NOT exist on my previous old build) Any ideas? I might have to try down-grading rockbox versions, since I didn’t have this problem a year ago - that would be lame.

Ben Leggett commented on 2009-02-21 21:07

I had this problem on my e260 until I enabled both the “Load database to ram” AND “Directory Cache” options. Hasn’t happened since.

Mike Edwards commented on 2009-03-21 03:00

I had this problem on my iPod and phanboy4’s fix did the trick for me as well. Maybe those settings could be enabled by default?

Justin Hannigan commented on 2009-04-15 02:56

Ideally this will give some clue about the source of the bug and it can be squashed instead of worked around.

Frank Oosterhuis commented on 2009-06-16 08:51

I yesterday enabled ‘auto-update’ Since this morning I have duplicated entries aswell.

can anyone confirm this?

Frank Oosterhuis commented on 2009-06-16 09:00

To be complete, device and rockbox info

Device: Sansa Fuze
Rockbox version: r21206M-090608

Frank Oosterhuis commented on 2009-06-17 15:52

when i disable ‘auto-update’ and reboot the player, all duplicated entries are gone

MichaelGiacomelli commented on 2011-04-17 23:21

Is this bug still present?

Ben Leggett commented on 2011-04-18 00:04

Not for me on Fuze V2. I’d say it can be closed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing