FS#8427 - Empty screen in filebrowser

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Monday, 07 January 2008, 22:14 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 08 January 2008, 08:12 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


It sometimes happens when you leave a directory in the filebrowser or Database browser that the items in the current directory are not visible and only appear after some scrolling.

Enable "Paged Scrolling" and then enter a directory with multiple pages of items (should propably be more than in the parent folder) and highlight the last item. Then press LEFT to return to the previous directory.

This was propably caused by the changes in r15947 (i was not able to reproduce this with r15946).

Still happens with r16018 (H300 uisimulator).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 08 January 2008, 08:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  thanks
Comment by Scott Tinman (sctinman) - Tuesday, 08 January 2008, 04:29 GMT
I was able to reproduce this with the sansa e200 with r15996 and r16019 (on simulator)
Comment by Scott Tinman (sctinman) - Tuesday, 08 January 2008, 07:53 GMT
Okay, I'm pretty sure it's a problem in centering the list--for paged scrolling, it assumed that the selected item is one page away from start_item (the item at the top of the current viewed page), and when changing directories the selected item is changed but not the starting item. Thus, problems come up for differences greater than the number of lines on a page ;]

I have a patch that fixed it for me in the simulator, but I used integer divides =/ not sure how efficient it is on these platforms, it was just a quick-fix...