Rockbox

Tasklist

FS#8444 - iriver H340 charging via cradle

Attached to Project: Rockbox
Opened by Ed Wilson (anomaly) - Friday, 11 January 2008, 11:50 GMT
Last edited by Steve Bavin (pondlife) - Monday, 14 January 2008, 13:16 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've just installed rockbox for the first time on my H340 and am noticing a similar problem as above. Something in the installation of rockbox has changed the behaviour of the iriver firmware when placed in the docking cradle for charging (not connected via USB).

Before rockbox
----------
1) H340 placed in cradle to charge
2) Backlight comes on and 'Charging...' screen appears
3) Backlight goes off (around 20 seconds?) and player continues to charge
4) Once complete backlight comes on again and 'Complete' message appears
5) Backlight goes off (around 20 seconds?) and player doesn't use any more power

After rockbox
----------
1) H340 placed in cradle to charge
2) Backlight comes on and 'Charging...' screen appears
3) Backlight stays permanently on while charging and player continues to charge
4) Once complete 'Complete' message appears
5) Backlight remains on with 'Complete' message on screen and starts to run down battery
6) Once removed from cradle user must press 'STOP' to remove completed message
7) Iriver firmware screen shows briefly before unit powers off

Ideally either
a) The behaviour should be the same as before rockbox
b) Rockbox should load and charge in a more friendly way than the iriver firmware above
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 14 January 2008, 13:16 GMT
Reason for closing:  Not a Bug
Comment by Steve Bavin (pondlife) - Friday, 11 January 2008, 15:31 GMT
Which versions of the IRIVER firmware did you have before and after the update?

With the SVN bootloader, insertion of USB starts up the Rockbox Bootloader USB mode, with player charging (apparently, just the battery voltages is displayed). Removal of USB then boots up Rockbox as normal, so it would lose a little charge (though the HD spins down and backlight turns off as configured). The Idle Poweroff setting then turns the device off completely.
Comment by Ed Wilson (anomaly) - Friday, 11 January 2008, 17:46 GMT
Before the update I had 1.30 I think (EU version). I used the automatic windows installer for rockbox and now have 1.30 E.

USB comments above are irrelevant - no USB cable is involved. I am using the docking cradle with power cable attached only.
Comment by Steve Bavin (pondlife) - Friday, 11 January 2008, 21:39 GMT
OK, with the SVN bootloader, applying power puts it into Rockbox charging mode (with backlight on). Removal of power then turns the device off.

i.e. I think this has already been fixed, but it's awaiting a new release of the H300 bootloader.
Comment by Peter D'Hoye (petur) - Sunday, 13 January 2008, 19:45 GMT
With current bootloader we boot into iriver OS when powered on by attaching power.
So I would say that rockbox is not involved.
Comment by Ed Wilson (anomaly) - Monday, 14 January 2008, 13:13 GMT
Yeah, I'm pretty sure this isn't a bug now. An installation of rockbox will clear out any old iriver firmware settings and for some reason the defaults are for the backlight to be always on when plugged in. Switching this to a small timeout in the iriver firmware seems to resolve the problem. For reference there is a forum thread discussing this issue - http://forums.rockbox.org/index.php?topic=13315.0

Loading...