Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2003-01-28
Last edited by bagder - 2003-12-05

FS#845 - fm rec : battery display indicates incorrect values

battery display indicates too low charge…and is blinking

fm recorder build 2003-01-28 17:20:00

Closed by  bagder
2003-12-05 09:32
Reason for closing:  Fixed
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Battery level runs from 1.8 volts to 3.4 volts, and decay seems fairly steady.
Patch file for voltages and voltage curve available at
www.mikeholden.uklinux.net/rockbox/powermgmt.ch.diff

Project Manager
zagor commented on 2003-03-18 14:36

Is this still a problem?

As promised on the mailing list, here’s a patch to show the
charging status for the FM in the status bar and in the battery
debug screens..

Introduces a new #define HAVE_CHARGE_DETECT, which is
defined for recorder and FM models.

Replaces charge_state global variable with charger_status()
global function.

Compiles cleanly for all 3 models, but only tested on FM.

Posted the attachment to the mailing list. How do you attach a file here?

Anonymous Submitter commented on 2003-06-07 17:36

yeah my Jukebox is having the same problem of displaying
incorrect values…

you may not have set the correct battery mAh settings…

General → System → Battery Capacity :
change it to
- 2200mAh for FM recorder
- 1500mAh for older recorders, 1800mAh for newer recorders
(best to check this by openning yours up and seeing what the
battery capacity is)

In what way are the values incorrect? What is it displaying,
and what sdo you think it SHOULD be displaying?

I am curious to know what people think the problem is here.

Project Manager
zagor commented on 2003-11-20 00:20

This is fixed in CVS.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing