Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Harshit - 2008-02-03
Last edited by Marc Guay - 2008-04-03

FS#8552 - c200: Some Plugins Shut Screen Off

RockBox Version:r16209-080203

Problem occurs as soon as an attempt to play the video is made.After the preliminary startup screen of the MPEG player plugin(After either “play from beginning” or “Resume at _:__” is selected)

Description:The display turns off leaving the backlight on. However, the sound of the video can be heard. The buttons are normally functioning. RockBox remains completely functional but for the display which does not resume even after we exit the MPEG player(By pressing the menu button).Hence the player has to be switched off.

The problem was produced with all videos, including http://download.rockbox.org/mpeg/elephantsdream-q6-144x80-131kbps.mpg which ran perfectly for another user.
(Ref: http://forums.rockbox.org/index.php?topic=14745.0)

Note: Users of the c200’s in which the problem occurred also reported exactly same results when the Jewels And/Or Star games were run on their players.


Closed by  Marc Guay
2008-04-03 14:35
Reason for closing:  Fixed
Mark Arigo commented on 2008-03-18 14:48

The attached patch fixes these problems for my c250.

I’ve also attached a compiled version for people to easily test. Use a current rockbox build and replace the .rockbox/rockbox.mi4 with the one I’ve included in the zip file.

waldo frinkazoid commented on 2008-03-18 19:56

i had a similar but slightly more anoying problem, when the player (a sansa c250) went into standy (turned its screen off) and i pressed a button, the backlight went on but the screen stayed black. This didn’t happen all the time and not in the mpeg plugin … just while playing music. I’ve since installed your version and i’ve not had this problem again. tnx

Malcolm Tyrrell commented on 2008-03-30 17:07

The display on my C250 wasn’t working when I used album art. This patch fixes that problem for me and also fixes the bug  FS#8825 .

Marc Guay commented on 2008-04-03 14:00

Also reported with the Calculator plugin, see related tasks.

Malcolm Tyrrell commented on 2008-04-03 14:29

The above patch has been committed:

http://svn.rockbox.org/viewvc.cgi?view=rev;revision=16896

Builds subsequent to this revision are working for me.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing