Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by sing - 2008-02-14
Last edited by pondlife - 2008-04-07

FS#8606 - WMA - Data abort at 03F03400 (0)

I am using a iPod Video (5.5G 80g) with Rockbox (r16225-080205), and when I play a song (in wma format), rockbox hanged with the following error message:

Data abort
at 03F03400 (0)

As I set the Rockbox startup with the Resume Playback, I cannot use the Rockbox anymore, since each time I reset my iPod, the Rockbox quickly turn to the Playback screen and try to play that song, so it hanged with the same error message again. It is a dead loop! Cry

I tried to update the Rockbox to version r16308-080214, but still got the same error.

Seems this problem only occur with that song, because I had play other songs with Rockbox with no problem.

The following is the information about the song causing the error, hope that can help:

Codec: Windows Media Audio 9.1
Compression: 32kbps, 44KHz, stereo 1-pass CBR
Bitrate(Kbps): 32

The attached is the song causing error.

Closed by  pondlife
2008-04-07 09:40
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed in r17011 or later.

Reproducible on Sansa e200 w/ 16290. Plays fine in Windows with WinAmp. Removing all tags did not help. Error for me is @ 01F03400 (0).

Reprodicible in the sim too; gdb gives:

0x05594b1f in wma_decode_frame (s=0x55ae028, samples=0x55aa028) at wmadeci.c:1148
1148 *ptr++ = level;
(gdb) print ptr
$1 = (short int *) 0x55a9d46
(gdb) bt
#0 0x05594b1f in wma_decode_frame (s=0x55ae028, samples=0x55aa028) at wmadeci.c:1148
#1 0x0559695b in wma_decode_superframe_frame (s=0x55ae028, samples=0x55aa028,
#2 0x055926d0 in codec_main () at wma.c:566
#3 0x055927f3 in codec_start (api=0x46eb40) at codec_crt0.c:51
#4 0x00441e53 in codec_load_ram (size=240730, api=0x46eb40) at codecs.c:222
#5 0x00441fd4 in codec_load_file (plugin=0x47c592 “wma”, api=0x46eb40) at codecs.c:264
#6 0x0043ff3e in codec_thread () at playback.c:1278

Just to throw it out there, perhaps if the player is set to start in “now playing”, and it crashes, Rockbox might have a function which resets that one option to the default (the main menu, I believe). Seems like it might be a safe thing for the firmware to do, if it’s possible to code in that way.

This has never happened to me, however (I myself start up in the main menu), so yeah. If that suggestion is somehow useful, I’m glad.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing