Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jono - 2008-03-05
Last edited by Marc_Guay - 2008-07-14

FS#8685 - Large Playlist showing wrong amount of tracks and shuffle error

Large playlists seem to add one extra track than what is actually is being recorded on the system information..

i.e system info reports 284 tracks yet playlist shows 285..

When on shuffle mode with the playlist, any track can then often be duplicated, this happens randomly and can be any track..

i.e same track will randomly play after another one when it has already been played..

Been doing it from build approx 16500, although maybe earlier as I was without the mp3 player for a week or so before I updated again..

Closed by  Marc_Guay
2008-07-14 02:27
Reason for closing:  Works For Me
Additional comments about closing:  

Cannot reproduce what I understand the problem to be. Similar bugs have been fixed recently. If it reoccurs please report.

Could you please confirm which SVN revisions you've actually tested this in?

jono commented on 2008-03-05 19:28

I installed the firmware on my current sansa from r16499 the problem has been from then on in really.. Was without the sansa for a week or so whilst it got exchanged, as my original one became faulty.. Im currently using r16520-080304 build and the fault i described is still current.

The old player was on build r16308 before it became faulty, did not seem to come across this problem back then..

HTH

Please update to the current build and verify it still happens. Specifically the build on the Current Build page, not Daily Build page.

Two things:

1) How are you loading the playlist? If it's from a file, what's the extension (m3u or m3u8)? I wonder if we've changed some char decoding and the playlist really contains 285 entries, but one file contains an extended character (or isn't named correctly).

2) Could you try build r16308 (or older) again and verify that the problem then goes away? Suitabla builds are here: http://www.rockbox.org/dl.cgi?bin=sansac200

jono commented on 2008-03-06 10:40

Will do both suggestions you guys have mentioned and investigate a bit more, report my findings later this evening (uk time)

Playlist was generated in Rockbox
Select pressed on the Music folder then added to catalog and saved as playlists\music.m3u8, playlist reports adding 285 track to the playlist..
Switched to shuffle mode, then when running that playlist the random duplication of a any random track happens when playing or skipping through the playlist in the WPS screen.

Have an exam to day so no time to address it as yet…

I'm trying to test this but don't understand where you're getting the second number from. What do you mean by "system info reports 284 tracks"?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing