Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Harlin - 2008-03-07
Last edited by Marc_Guay - 2008-04-01

FS#8698 - Freeze & Undefined instructions at 022B992C (0) on RB r16536-080306

I use Rockbox r16536-080306 on my ipod video 5.5g 30gb.

I have encountered error (intermittent, not only one time):
- when I play FLAC, and do often skipping track, rockbox freeze and show: Undefined instructions at 022B992C (0)
- when I play mp3 in playlist to break-in my headphone, rockbox also freeze but I could not seen the error message because lcd is off.
- then I restart my ipod, all setting is lost. I re-set theme&crossfeed, shutdown rockbox normally and start it, again all setting is lost.

After chkdsk /f my ipod, it turns out rockbox config file is corrupted.
Maybe because rockbox freeze when writing to disc.

This is my config files:

# .cfg file created by rockbox r16536-080306 - http://www.rockbox.org

volume: -22
repeat: off
idle poweroff: 5
brightness: 8
foreground color: FFFFFF
crossfade: always
crossfeed: on
dircache: on
tagcache_ram: on
tagcache_autoupdate: on
font: /.rockbox/fonts/nimbus-12.fnt
wps: /.rockbox/wps/Black Glass AA.wps
backdrop: /.rockbox/backdrops/Black Glass AA.bmp
usb charging: on

Closed by  Marc_Guay
2008-04-01 11:51
Reason for closing:  Not a Bug
Additional comments about closing:  

Caused by file corruption.

Has this happened recently? Can you provide any other indication of what causes it?

Since updating my rockbox to recent release, I have encountered Undefined Exception once (but with different error codes).
And since I scan my ipod disk for error and defragment it, I never have encountered an error that would cause disk corruption.
When ipod disk is fully defragmented, file access has been improved too.
Thanks for your attention.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing