Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by gilesn - 2008-03-11
Last edited by bluebrother - 2008-03-20

FS#8723 - ipod 5g, mp3 tag genre field garbled

mp3s (ID3 v1 only tagged) with genre 'Comedy' show up as '(57)' in database browser. Also 'Cult' shows as '(58)'. Other examples exist.

Closed by  bluebrother
2008-03-20 23:01
Reason for closing:  Not a Bug
Additional comments about closing:  

issue with files tags, not Rockbox. See comments for details.

What program are you using to tag your files? Is it only the Genre field that you have this problem with? Please provide as many details as possible.

Hi Marc, Not show how these were tagged originally however I'll attach a coupla sshots, maybe this gives you enough info, Cheers.

   g.txt (0.7 KiB)
   untitled.JPG (155.9 KiB)

I mean 'Not sure'! BTW, all other fields showing OK.

Some guesses as to what is causing this:
1) There's a mention of image/png in the header file you attached. Do you have embedded album art?
2) The Genre field is a pull-down menu in your tagging program. Is Comedy the 57th item on the list? Is Cult the 58th? It could be a problem with the program. Do the tags display properly in other programs (i.e. iPod firmware, WinAmp, etc)?

1) No embedded art according to tagging program nor does it appear when playing in original firmware, maybe was there in the past when using itunes?
2) No, Comedy is about 30th on list. Genre displays OK when playing with iPod firmware, Windows file property box, Banshee and Rythymbox under Ubuntu.

Do *any* of the Genre tags created by this program show up properly in Rockbox?

As I understand how ID3v1 works, there is a a code in the tag that corresponds to a predefined list of genres. You can find the list of codes and associate genres here: http://www.linuxselfhelp.com/HOWTO/MP3-HOWTO-13.html#ss13.3

The code for comedy is 57 and the code for cult is 58. So it seems that this is not a problem with the tagging program, but with the way that Rockbox is displaying the genre associated with each code.

That looks like the case. I have Pop mp3s showing as '(13)', Rock as '(17)', all ID3v1.

are you absolutely sure your tagging tool didn't wrote the genre numbers to any id3v2 field? I had this once.

If the attached file g.txt comes from one of the files that shows the problem, then at least that file does have an ID3V2 tag. If Rockbox finds an ID3V2 tag, then any ID3V1 tag will be ignored. I couldn't see any genre tag in the ID3V2 tag part, but I'm not sure if g.txt contains the full ID3V2 tag (don't want to try to decipher the tag length just now :).

I rewrote the tag using a program called 'Easytag' in Ubuntu and now the genre appears OK. I guess that the original tag contained the code rather than the genre name and rockbox doesn't interpret the codes.

Rockbox does interpret the codes, but it is a little picky about the format. E.g., for ID3V2.4 tags, the genre code should not be enclosed in parentheses (this behavior matches the specification).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing